wireless help with wep authentication

Rob Clark rpclark at tds.net
Sun Nov 20 17:55:43 UTC 2011

Running fbsd 8.2R on a Dell C640 laptop.
Using a pcmcia card with atheros.

My 2wire wireless router comes setup default with
wep open with wireless security enabled, i.e., needs
the default passkey from the router.  I cannot get the 
ifconfig line correct so as to authenticate this way, 
and have tried many different strings of text here.

However, following the handbook, I turned off "enable
security" (on the 2wire router) to test things, hence,
using wep (not as authmode shared or authmode open)
and it works using the following in /etc/rc.conf:

ifconfig_wlan0="ssid Mynetname DHCP"

Mynetname is different -- of course.

I can browse the web and ping with 0% packet loss.

I have not delved into using
a /etc/wpa_supplicant.conf yet, I was 
hoping i could get it done in rc.conf with ifconfig.

I have tried many many things, for days on end for
authenticating with the passkey from the router.
Any help appreciated, I can provide further info and
things I've tried -- most things in the handbook
wireless section, minus wpa_supplicant.conf.

Thanks In Advance,

More information about the freebsd-questions mailing list