where to ask about problems with bsdinstall in 9.0RC2?

Ian Smith smithi at nimnet.asn.au
Sat Nov 19 18:29:27 UTC 2011

In freebsd-questions Digest, Vol 389, Issue 8, Message: 6
On Fri, 18 Nov 2011 19:08:22 -0500 William Bulley <web at umich.edu> wrote:
 > According to Edward Martinez <eam1edward at gmail.com> on Fri, 11/18/11 at 19:53:
 > > 
 > >    Have you tried installing with "ACPI" disabled.
 > >    
 > > http://www.freebsd.org/doc/handbook/bsdinstall-install-trouble.html#Q3.10.2.1.
 > > 
 > >      this also may be of some help:
 > >      http://www.freebsd.org/doc/handbook/bsdinstall-partitioning.html
 > Thanks.
 > I will try disabling "ACPI" but this wasn't necessary for the install
 > of 8.2-RELEASE from CD which, as I said, went in just as I expected.

I doubt that's your problem, going by my experiences with BETA1 and 
following the freebsd-current archives for a couple of months; others 
have described similar problems installing over existing slices, and in 
my mind it points to a relatively large deficiency in bsdinstall versus 
sysinstall (still available from 'Live CD' mode, at BETA1 anyway)

 > I would not think that much would have changed in 9.0RC2 in this area.
 > Maybe I am wrong about that.
 > The second URL describes the Manual vs. Guided install and partition
 > section of bsdinstall.  I had read this several days before the 9.0RC2
 > install attempt from DVD.  It seemed pretty reasonable, but a little bit
 > different from sysinstall.  Was worth a try.

Unfortunately that concentrates on creating a GPT layout, encouraging a 
Linux-like single (plus a boot) partition - forget using dump/restore -
and says nothing much about installing over an existing setup with MBR 
partitioning and multiple slices, a not uncommon setup on many existing 
laptops .. eg here I want to install over a previous 7.2-RELEASE 60GB 
slice partitioned as I want it - 1GB /, 4GB /var, 16GB /usr and ~37GB 
/home.  Further, I want to preserve /home as is, despite having backups.

 > What I saw when I selected Manual partitioning, was a complete tree:
 >     ad0
 >        ad0s1               [FreeBSD Boot Manager from 8.2]
 > 	  ad0s1a   xxxx    [was my previous root partition]
 > 	  ad0s1d   xxxx    [was my previous swap partition]
 > 	  ad0s1d   xxxx    [was my previous /var partition]
 > 	  ad0s1e   xxxx    [was my previous /usr partition]
 > or something very close to that, missing only my mount points from my
 > previous 8.2-STABLE system.  I added the mount points (this is the area
 > where I thought bsdinstall had some weaknesses in the "User Experience")
 > and went on after selecting "Finish".

sysinstall's partitioning is more sophisticated; you get to specifically 
toggle on or off newfs'ing each partition, as well as specifying newfs 
options if you want.  So it's clear whether you'll be newfs'ing / and 
which other partitions, and which you'll be leaving alone, eg /home.

 > The problem occurred much later after I selected all four install files.
 > When I said the equivalent of "Go", it began the process of loading them
 > off the DVD, checking their checksums, and compressing them prior to
 > installing them.  It was while processing the first (base.txz) chunk
 > that the popup appeared giving me the "unable to write" or "unable to
 > uncompress" message.  Can't recall the exact error now some hours later...  :-(

On BETA1 I recorded "Extract Error while extracting base.txz: can't set 
user=0/group=0 for /var/empty Can't update time for /var/empty .." which 
someone/s else also reported, which turned out to be misleading .. the 
basic problem is that the filesystem isn't empty, ie as after newfs.

The workaround given then was to boot in Live CD (aka Fixit) mode, and 
newfs the appropriate partitions, manually or with SADE - in your case 
probably all of /, /var and /usr - and then rerun the install onto clear 
partition/s; it's not and never should be required to scrap existing 

Something else not clearly evident to me is (or at least was) that if 
you don't supply a mountpoint for a partition, it won't be used; in my 
case I'd have to leave my /home partition unmentioned so it would be 
left alone .. after all, every partition on every slice is listed as a 
possible install target.  I admit not having tried this again since, 
after feeling a bit lucky not to have destroyed my whole 7.2 slice, but 
that was BETA1 after all ..

I haven't yet discovered whether or how bsdinstall handles setting 
boot0cfg for multi-boot systems, and I've seen no mention of boot0cfg or 
anything similar (apart from Linuxisms like GRUB) for GPT setups at all.

 > So the extraction step failed the first file, and I never made it to
 > the Post-Installation phase, sigh...  :-(

Yep.  I'd hoped this might be fixed (or at least documented?) by now, 
but I think bsdinstall has to be considered still in development at this 
stage - ie, for 9.0 - except for such as installing to new systems, for 
which it appears to be working very well.  Some have implied that the 
sort of installs we're attempting should require prior expertise, but 
even people who've been installing FreeBSD for a decade or so have been 
confused by this one, and you shouldn't need to read current@ to know 
how to deal with this sort of installation error, in my view.

Fortunately sysinstall is still there, and while it can't handle GPT 
partitioning, should still be useful for partitioning and maintaining 
many existing systems.  I've yet to install RC1, and here's RC2, but I'm 
encouraged to see the memstick.img has dropped GPT partitioning for MBR 
with a single provider (eg da0a) so it can be again used by sysinstall; 
in my case I'd rather use that than manually newfs needed partitions.

I hope someone will correct any now-obsolete concerns I've expressed :)

cheers, Ian

More information about the freebsd-questions mailing list