where to ask about problems with bsdinstall in 9.0RC2?

William Bulley web at umich.edu
Fri Nov 18 23:00:03 UTC 2011

According to Matthew Seaman <m.seaman at infracaninophile.co.uk> on Fri, 11/18/11 at 17:41:
> On 18/11/2011 21:27, William Bulley wrote:
> > I tried to install 9.0RC2 from the DVD ISO today.  This defaults
> > to using bsdinstall instead of the 8.x sysinstall.
> > 
> > This process gave me an error, but I'm not sure in which forum
> > to discuss this problem/error.  Thanks in advance.
> freesd-questions@ is fine to talk about this sort of problem. At least,
> initially.  Give us more detail on exactly what you did, what then
> happened, (and maybe why you think that was wrong) and we can probably
> help you get your system installed.
> If it turns out to be a bug in the new installer rather than operator
> error, then freebsd-current@ is the place to take it.

Okay, here goes.   :-)

I was loading a decent but somewhat older Dell laptop with FreeBSD
for a friend who bailed since he didn't want to bother configuring
Xorg.  Since this is fairly trivial these days, I said, "sure, I'd
do that for you" - silly me...   :-(

Anyway, do to the user requirements, I found it necessary to load
a version 9.x system on this laptop.  I burned this version to DVD:


The laptop had no trouble booting from this DVD.  Unfortunately, I
forgot about the new bsdinstall program.  I was dubious but it seemed
to start out okay.  I had some User Interface issues with the Manual
disk partition screen, but that is a matter of taste or a feature
request, and not the bug.

Everything progressed just fine as the various *.txz files were
loaded, checked and installed.  Or so it seemed...

As the progress bar moved to the right toward 100% completion, a
window popped up telling me that it (bsdinstall) could not handle
the base.txz (BTW, what does the suffix ".txz" mean?) - it could
not uncompress it and said something about "unable to write" and
the string was something like: "var/base.txz" (note the lack of
a leading slash in front of "var").

It asked me if I wanted to continue or restart and I said "yes",
but the bsdinstall started over from scratch and failed in the
same manner.

Unfortunately I had to bail on the attempt...   :-(

Prior to this, I had loaded and configured 8.2-RELEASE and had
upgraded it to 8.2-STABLE.  I csup'd the ports tree and built
enough ports to run Xorg.  And I got X11 running after a bit.

But when I tried to upgrade again to 9.x (anything) I ran into
problems there (slips my mind why at present) which led me to
trying the FreeBSD-9.0-RC2-i386-dvd1.iso approach.  What a mess...   :-(



William Bulley                     Email: web at umich.edu

72 characters width template ----------------------------------------->|

More information about the freebsd-questions mailing list