X server and xinit works excellent....almost.

Samuel Magnusson samuel.magnusson5 at bredband.net
Thu Nov 10 01:02:36 UTC 2011

Polytropon wrote 2011-11-09 19:19:
> On Wed, 09 Nov 2011 13:19:44 +0100, Samuel Magnusson wrote:
>> This works for me:
>> X :0 -terminate
>> Ctrl-Alt-F1
>> xterm -display :0
>> Ctrl-Alt-F9
>> exit xterm.. which brings me back to the first console.
>> But this doesn't work:
>> X :0 -terminate vt4
>> Ctrl-Alt-F1 (doesn't respond)
>> Ctrl-Alt-Backspace (doesn't respond)
> Do you have ``Option "DontVTSwitch" "false"'' in xorg.conf?
No I haven't, so I tried it now for completeness sake. But there was no 
difference. It shouldn't be needed, and VTSwitching works just fine as 
long as I don't try to choose a virtual terminal to start it in. I tried 
putting the option there and it is no difference, the computer hangs on 
the display, and when viewing sockstat -4  from the remote login I could 
see an awful  lot of dbus and hal activity.

Since those 'fellas' were the cause of so many of my woes I disenabled 
them :) , rebooted and tried again. At first no difference except that 
when I killed the server I was no longer stuck with the black screen and 
visually returned to tty0. I was not given back the console though and 
the login was still hanged.

>> Any clue why? Is my command "X :0 vt4" wrong or not supposed to work?
> What is the correct notation for the terminal device to start
> it on? Maybe ttyv4 (as in /etc/ttys)?
Nope. Even if I no longer trust the Xorg man page to 100%, it clearly 
states vtXX as the notation to use for the option. And when viewing the 
log it clearly says that it start up the server in vt4 and it doesn't 
protest but goes on a good while before it stops. Interesting is that it 
stops without any error message. It is right after reading the 
keyboardsettings from xorg.conf, the first informational line after that:

(II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD)

Then the file ends.

More information about the freebsd-questions mailing list