kernel and buildworld questions

Mage mage at
Tue May 10 17:58:30 UTC 2011


I just arrived to FreeBSD soon after I met silent data corruption on one
of my software raid mirrors and went looking ZFS capable OS.

So far I like it, I suppose I will migrate, however some issues appeared

First of all, I think this manual doesn't work anymore:

I did it very precise multiple times and I tried the other version too
(create zroot /dev/ad0s3a vs. create zroot /dev/ad0s3). After googling a
while I think the MBR bootloader just doesn't work for pool version 15+.
It hangs on boot. I tried with 8.2 installer, snapshot and PC-BSD too. I
ended up UFS boot + ZFS with PCBSD install disk (but FreeBSD install).

Later I will try GPT manually. My question is that does the FreeBSD
kernel and its loader use some kind of checksuming? Initially my move to
FreeBSD was inspired by the fear of bit rot. Maybe it seems to be
paranoid but I would like to be sure that everything loads in perfect
condition. Even the kernel image. Is it checked somehow in case of UFS boot?

After installing the system I upgraded it to the current release by the
manual. Upgraded zpool to v28. I installed Xorg, KDE and E17 from ports.
Everything was fine and working. Then I played with /etc/make.conf and
accidentally set incorrect CPU type (I missed my laptop with my
desktop). I set athlon64 instead of core2. After some installation and
testing I realized that cvsup stops with signal 4. So does 'rvm install
1.9.2' (ruby userspace installer).

Other things like Xorg and KDE were still working.

I decided to repair the system instead of reinstalling. Not because I
have anything valuable on it. Just because I would like to learn FreeBSD
fast and I think that fixing errors helps more than blind reinstall with
a GUI.

In my dmesg I see this:

pid 2780 (cvsup), uid 0: exited on signal 4 (core dumped)
pid 8865 (cvsup), uid 0: exited on signal 4 (core dumped)
pid 27368 (miniruby), uid 1001: exited on signal 4 (core dumped)
pid 34725 (cvsup), uid 0: exited on signal 4 (core dumped)

Other commands don't do signal 4 (gcc, make, and related things work) it
doesn't look really bad for me.

First I thought the signal 4 is because some ports were compiled with
bad cflags. Deinstalling and reinstalling didn't help. After some failed
attempts I finally ran:

portupgrade -afkP

I think this replaced all my ports to binary packages. However I still
got signal 4 for 'rvm install' and 'cvsup' both.

I fixed my make.conf to 'core2' cpu and removed everthing else (cflags),
and made:

cd /usr/obj
rm -rf *
cd /usr/src
make cleandir
make cleandir

make buildworld
make buildkernel
make installkernel
make installworld

And this didn't help.

After this I was not sure even core2 is fine in make.conf (yes I have
core2), I changed it to 'CPUTYPE?=native', without defining any cflags I
rebuilt the world and the kernel and I still get signal 4.

It does frustrate me. I should be able to fix it. Actually I am
recompiling the world without any make.conf, but it takes hours. How
should I repair my test system? What did I miss?

Thank you.


More information about the freebsd-questions mailing list