Firefox URL Address Bar does not work under 8.1-RELEASE

Devin Teske dteske at
Mon May 9 22:35:49 UTC 2011


> -----Original Message-----
> From: owner-freebsd-questions at [mailto:owner-freebsd-
> questions at] On Behalf Of Devin Teske
> Sent: Monday, May 09, 2011 12:22 PM
> To: Gautham Ganapathy
> Cc: FreeBSD
> Subject: Re: Firefox URL Address Bar does not work under 8.1-RELEASE
> On May 8, 2011, at 4:27 PM, Gautham Ganapathy <gautham at>
> wrote:
> > On Sat, May 7, 2011 at 10:42 PM, Devin Teske <dteske at> wrote:
> >> Hi list,
> >>
> >> I hope that you can offer some suggestions to help make some sense of this
> odd situation. The situation is that we install FreeBSD 8.1-RELEASE onto
> Intel workstation hardware. We then add about 400 packages to the system. On
> top of that, we then add firefox.
> >>
> >> Everything works great in the system, even firefox ... that is until you
try and
> use the address bar in Firefox to enter a URL. Pressing ENTER has no effect.
> Neither does clicking the green arrow to the right of the URL in the address
> Meanwhile, requesting firefox to visit a URL via the command-line works just
> fine. Clicking through pages and navigating links also works fine. The entire
> system is functional with except to the URL address bar in Firefox.
> >>
> >> We then set up a second machine (also workstation-class hardware, though
> much newer). Same thing. System works superbly, with exception to firefox's
> address bar.
> >>
> >> Co-workers and I are scratching our head over why this is happening.
> >>
> >> We've tried both firefox-3.6 and firefox-3.5 from the FTP archives. We've
> always installed every dependency. Both browser versions have the same
> problem. Both machines have the same problem.
> >>
> >> Specifically speaking, we've tried these two packages:
> >>
> >>
> >> ackages/All/firefox-3.6.4,1.tbz
> >>
> >> ackages/All/firefox-3.5.10,1.tbz
> >
> >
> > I had a similar problem under Windows sometime back after an upgrade.
> > Resetting the profile worked for me. Try backing up your
> > $HOME/.mozilla directory, deleting it and starting firefox afresh.
> That didn't help. :'(
> > Someone also suggested resetting the toolbars.
> Also doesn't help -- though introduces a new buggette.
> If I go to View -> Toolbars -> Customize... in the menubar and simply click
> to dismiss the "Customize Toolbar" dialog, now the menubar in the main menu is
> grayed-out (every menu) and you cannot open any menus (you have to forcibly
> close the app and restart it to get your menubar back). Again, this is both
> 3.5 and 3.6 from FTP, occurring on multiple machines running 8.1-RELEASE.
> We've also tried different window managers (and no window manager) to no
> avail.
> Even tried -safe-mode to reset everything ;'(
> Just now also noticed that the search bar also acts the same way as the
> bar (enter does nothing and "go" button also does nothing).
> --
> Devin

Turns out that this rather odd behavior is reproduced by having an NFS-mounted
$HOME directory.

Executing something like the following allowed the browser to function properly:

	env HOME=/tmp firefox3

Is there any solution that could allow us to keep our home directories on NFS?

We presume that there's a lock-file that can't be generated on our NFS server
and that's what is causing our headache.


The information contained in this message is proprietary and/or confidential. If you are not the intended recipient, please: (i) delete the message and all copies; (ii) do not disclose, distribute or use the message in any manner; and (iii) notify the sender immediately. In addition, please be aware that any message addressed to our domain is subject to archiving and review by persons other than the intended recipient. Thank you.

More information about the freebsd-questions mailing list