Firefox URL Address Bar does not work under 8.1-RELEASE

Gautham Ganapathy gautham at
Sun May 8 23:27:51 UTC 2011

On Sat, May 7, 2011 at 10:42 PM, Devin Teske <dteske at> wrote:
> Hi list,
> I hope that you can offer some suggestions to help make some sense of this odd situation. The situation is that we install FreeBSD 8.1-RELEASE onto standard Intel workstation hardware. We then add about 400 packages to the system. On top of that, we then add firefox.
> Everything works great in the system, even firefox ... that is until you try and use the address bar in Firefox to enter a URL. Pressing ENTER has no effect. Neither does clicking the green arrow to the right of the URL in the address bar. Meanwhile, requesting firefox to visit a URL via the command-line works just fine. Clicking through pages and navigating links also works fine. The entire system is functional with except to the URL address bar in Firefox.
> We then set up a second machine (also workstation-class hardware, though much newer). Same thing. System works superbly, with exception to firefox's address bar.
> Co-workers and I are scratching our head over why this is happening.
> We've tried both firefox-3.6 and firefox-3.5 from the FTP archives. We've always installed every dependency. Both browser versions have the same problem. Both machines have the same problem.
> Specifically speaking, we've tried these two packages:
> --
> Cheers,
> Devin Teske
> Business Solutions Consultant II
> FIS -
> 510-735-5650 Mobile
> 510-621-2038 Office
> 510-621-2020 Office Fax
> 909-477-4578 Home/Fax
> devin.teske at

I had a similar problem under Windows sometime back after an upgrade.
Resetting the profile worked for me. Try backing up your
$HOME/.mozilla directory, deleting it and starting firefox afresh.

Someone also suggested resetting the toolbars.


More information about the freebsd-questions mailing list