emacs backspace question

Matthew Morgan atcs.matthew at gmail.com
Thu Mar 24 21:22:40 UTC 2011

I've read a lot on the internet regarding the use of the backspace key 
in emacs, but the proposed solutions don't seem to be working for me.

I just installed FreeBSD 8.1 in Virtualbox and installed emacs 23.2.1 by 
means of the package installer.  Everything in emacs works great except 
the backspace key, which deletes forward instead of back like it 
should.  I've found a lot of different things on the internet about it:

* switched to bash instead of csh - didn't fix it, but I like bash better
* M-x normal-erase-is-backspace-mode -toggling it once makes my 
backspace bring up the "help" command; toggling it again changes it back
* different keymaps
     - I started out using us.iso.kbd (which exhibits the backspace 
issue, but other keys are right)
     - I tried us.emacs.kbd - backspace works right, but many other keys 
are mapped wrong (even letters and numbers)
     - I tried us.unix.kbd - backspace doesn't work right and neither do 
my control keys

I also just noticed that when on the command line itself (outside of 
emacs) backspace deletes backward as it should, but so does delete!

Is this something weird with virtualbox, or am I doing something wrong?

More information about the freebsd-questions mailing list