Freebsd Firefox problems

O. Hartmann ohartman at
Sat Mar 19 16:01:57 UTC 2011

On 03/19/11 16:37, Sander Janssen wrote:
> I have finally managed to solve this issue. Upgrading to 8.2 didn't
> solve anything. But after I installed ccache I decided to recompile all
> my installed ports in the hope that it solved my problems. After
> recompiling all my ports (1000 ports, including openoffice). The problem
> still persisted.
> But after reading another thread I removed pulse audio support from
> libcanberra and this solved the problem. I first removed gstreamer
> support as well but this does not cause the problem.
> Regards,
> Sander

my installation of libcanberra doesn't have pulse-audio enabled anymore 
since enabling pulse-audio support in several other libs and apps 
resulted in problems updating via portmaster (as far as I can recall).

At this very moment, my firefox seems to be ok.


> On 07/10/10 09:37, Hartmann, O. wrote:
>> On 07/10/10 02:46, Sander Janssen wrote:
>>> Hello,
>>> I am currently having the same problems you were having with firefox
>>> 3.6 on FreeBSD in February (I found the threads on the Freebsd-Ports
>>> mailing list). The thread doesn't seem to come up with an answer and I
>>> am wondering if you managed to solve the problem?
>>> I am talking about firefox crashing when you use a context menu. I
>>> have tried a portupgrade -Rf firefox to try to recompile every depency
>>> but nothing has any effect. In my case thunderbird works correctly.
>>> Any information would be useful.
>>> Thanks in advance,
>>> Sander
>> Hello.
>> I have still this obscure problems. When "gettext" was updated and we
>> have had to update any dependend port, within this procedure Firefox 3.6
>> worked correctly as expected. But after the update was performed,
>> everything remained as it was before. I did several times portmaster -f
>> (which is the same as -R with portupgrade) to build every necessary
>> port, but with no effect. I also performed the one-day-taking gettext
>> update and, additionaly, I recompiled every port (nearly 1000 on my
>> systems). No effect.
>> When delegating the client firefox to another X terminal, say to my
>> workstation at home (login with ssh -Y for X11 portforwarding), no
>> problems occur, so I guess the problem is riggered by X11 on the local
>> machine and especially with the ATI radeonhd driver (which does not work
>> correctly on many boxes and with low end Radeon HD 46XX or 47XX cards).
>> I have no idea. I use Opera for now on the machine in question.
>> Regards,
>> Oliver

More information about the freebsd-questions mailing list