dhclient not working with wpa

Michael mlmichael70 at gmail.com
Tue Mar 8 03:33:01 UTC 2011


Problem is that my wireless card doesn't see any replies from DHCP 
server when I use wpa_cupplicant (it works fine without encryption), 
even tho it is associated with that access point.
So it looks like the encryption bit is working but then dhclient fails. 
If I turn the encryption off then dhclient works.

I've tried with isc dhclient both 31 and 41 versions. I've tried with 
manually setting IP/netmask and route. Nothing helps, my FreeBSD box 
just can't talk with the router over the wireless with encryption.

I know that the router is OK because other clients can get IP address 
without any problems. I know that wireless card is OK because it works 
with that access point from other operating systems, it also works with 
other access points.

I guess it may be related to PR number 145269. But it's marked as 
serious+open for a year now so maybe somebody got a working workaround?
Any suggestions please?


More information about the freebsd-questions mailing list