FBSD 8.2 and USB Floppies

Polytropon freebsd at edvax.de
Mon Jul 18 19:12:04 UTC 2011

On Mon, 18 Jul 2011 19:57:02 +0100, Pegasus Mc Cleaft wrote:
> On Monday 18 July 2011 19:45:27 James Colannino wrote:
> > 
> > newfs /dev/da0
> > 
> > It was successful.  I then tried to mount the new filesystem (mount
> > /dev/da0 /mnt), and got the same error: invalid argument.  Does FBSD
> > have a problem mounting USB floppy disks?  It's not a big deal, as my
> > other USB storage devices seem to work, and as I have an ordinary floppy
> > drive I can try, but that curious part of me wants to know why this
> > isn't working.
> > 
>  Have you tried: 
> 	mount_msdosfs /dev/da0 /mnt

You can alternatively use the "most portable file system"
which isn't even a file system: it is tar.

I've been using this approach among different UNIX, Linux
and Solaris systems that didn't have network connections.
The approach on FreeBSD is this:

	# fdformat -y /dev/da0
	# tar cvf /dev/da0 files...

and on the target system:

	# tar xvf /dev/da0

Add compression (z and j) if required.

In this example, da0 represents the USB floppy drive; a
regular one would be /dev/fd0. (Device names vary among
UNIX and Linux systems.)

Although this approach doesn't allow you to mount MS-DOS
formatted floppies, it's a good check to see if writing
and reading of the media works as intended.

For the mount_msdos command mentioned above, check if you
need additional masking flags as this file system doesn't
understand UNIX permissions (and therefore files are often

Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...

More information about the freebsd-questions mailing list