[SOLVED]Re: atheros 9285 wifi

freebsd-questions at herveybayaustralia.com.au freebsd-questions at herveybayaustralia.com.au
Sat Jul 16 00:38:36 UTC 2011

On Fri 15/07/11  7:46 PM , Vincent Hoffman  wrote:On 15/07/2011 03:15,
 > On Thu 14/07/11  9:28 PM , Maciej Milewski  wrote:On czwartek, 14
 > lipca 2011 04:25:59 Polytropon wrote:
 >  > On Thu, 14 Jul 2011 12:02:02 +1000, freebsd-
 >   wrote:
 >  > >  So are you saying I can't just grab the ath module?
 >  > 
 >  > Depends. Maybe a newer version of the module requires a more
 >  > recent version of the kernel, because a new interface or
 >  > function was added...
 >  > 
 >  > > I'd rather stick to release, but I guess if I'm having to
 > the
 >  > > kernel each update...
 >  > 
 >  > You _can_ try to just compile (1st step) and load (2nd step)
 >  > the module with the RELEASE kernel, but it's not guaranteed
 >  > to work. Both steps may require updates in sources or in the
 >  > running kernel as illustrated above.
 >  You may try to get ath driver from -HEAD and compile it with your
 > RELENG_8 
 >  tree[1]. There are many fixes for this chipset in the -HEAD. The
 > coming 9 will 
 >  have it(I don't know the timeframe for the release though)
 >  [1]
 > [2]"
 >  Ok, I tried that- I did look into running stable as well,
 > Polytropon  mentioned which twigged and I thought I might go that
 > but looking into it further it is still a development branch. I
 > I need a bit more stability for my users.
 > I bit the bullet and built subversion (which I'm more comfortable
 > than cvs) and pulled down ath from head (specifically
 > head/sys/dev/ath, head/sys/modules/ath, head/sys/modules/ath_pci -
 > tried stable as well, but got the same result as now). I'm having
 > trouble building though (if I need to switch to a different list
 > me know - just a little painful with no working network): I get
 > odd file not found errors on some includes (headers from ath_hal
 > specifically), and when I fix that I get HAL_PHYERR_PARAM not
 > errors which I can't quite figure out. A point in the right
 > will do; right now I'm getting lost in the maze a bit.
 > I'm going to keep trying to untangle this, but some assistance
 > be appreciated.
 are you following the instructions from Adrian (currently the ath
 here http://forums.freebsd.org/showthread.php%3Ft%3D23594 [4]"
 I do this myself and its working well. (atheros 9280 though)
 Arggh! I must be so tired... I completely missed the includes in
those instructions- and worse yet: I forgot them myself! Thanks for
the reminder :)
Works like a dream now, anyway. 8.2 with head ath drivers (for
Message sent via Atmail Open - http://atmail.org/

[2] http://webmail.unitedinsong.com.au/parse.php?redirect=<a href=
[3] http://webmail.unitedinsong.com.au/parse.php?redirect=<a href=
[4] http://webmail.unitedinsong.com.au/parse.php?redirect=<a href=

More information about the freebsd-questions mailing list