amd64 lib path locations

wayne mitchell wayne.mitchell.iz at
Mon Jul 11 19:23:08 UTC 2011

got a problem with an amd64 system and lib-object locations - see below:

problem:    installing of 'rosegarden'
installing is fine (from package - not port)
starting rosegarden from gui menu - nothing happens
executing rosegarden from CLI returns error:
[ /libexec/ shared object "" not found,
required by "rosegarden" ]

using 'find' to find the required object shows that it is on the system at:

i have compared this installation and setup to a desktop machine with same
setup and rosegarden works fine with that - details further on

system detail 1:
(laptop - rosegarden not working)
freeBSD 8.1-RELEASE amd64 - GENERIC kernel
on an intel core 2 duo cpu - laptop
using gnome2
separate slices for HDD:
(IDE 60Gb)
1:    swap
2:    /var
3:    /
4:    /usr
(environment MACHTYPE is set to 'unknown')

system detail 2:
(desktop - rosegarden works fine)
freeBSD 8.1-RELEASE i386 - GENERIC kernel
on an intel p4 cpu
using gnome2
separate slices for HDD:
(SATA 250Gb)
1:    swap
2:    /var
3:    /
4:    /usr
(environment MACHTYPE is set to 'i386')

you can see that the two systems are as similar as can be
both are fresh installations (official DVD dist.), with exact matching
installed packages
when making a search for the missing object:
it shows up in the same location on both machines:

my guess:
1.    could be anything
2.    i have no way of telling 'where' the '/libexec/' object is

    looking for the missing 'Qt3' opbject
3.    i prefer to use packages rather than ports, so i cannot check the
    code of the port for rosegarden or
4.    i have limited knowledge of the bsd system and so do not know where to

    start looking or how
5.    i suppose it could be a simple case of one missing symlink
6.    or an environment variable (see MACHTYPE above)
7.    i did at first consider that i had the wrong architecture system
    on the core 2 laptop (freeBSD distribution HARDWARE.HTM shows that amd64

    system supports intel core 2 - not core duo) i have no extensive
    knowledge and all i know is that the 'sticker' on the laptop says
    'core 2 duo' - which confuses me ( is it core 2, or core duo..?)
    have tried installing i386 system, which worked to a point,
    console seems okay but gnome2 trips up - hangs with no obvious errors
    reported to console - so this caused me to revert bcak to amd64 system
    now gnome works fine other than this problem with lib-elf & rosegarden
8.    both hard drives are sliced the same way (slice order and mount
    - only difference is bus I/O type and size (IDE vs. SATA)
9.    it could be the architecture distribution (amd64)

late addition:
just tried the same thing with a desktop amd64 setup -
exact same characteristics as the laptop above

More information about the freebsd-questions mailing list