8.1-STABLE: Weird behaviour with some network services

Kamigishi Rei spambox at haruhiism.net
Sat Jan 22 08:38:14 UTC 2011


I'm running FreeBSD 8.1-STABLE amd64 r215423 on a Q9400 with 6GB RAM.
Base system is on a geom_mirror, everything else is inside a few ZFS
raidz1 pools. Everything except sshd runs inside jails.

Three days ago I noticed that my audio/icecast2 (2.3.2, from ports)
suddenly stopped processing connections. Couldn't stop it
conventionally, either; only kill -9 worked.

Then the same day Apache's httpd (2.2.18, prefork, built manually)
stopped responding; child processes were stuck in <defunct> state and
never finished, and the dispatcher didn't spawn any new ones. However in
this case 'apachectl restart' worked, and defunct processes were
successfully killed.

With gdb attached to icecast2, I can see 6 threads running, all of them
except two being inside nanosleep(). The main process seems to be stuck at

453         ret = poll(ufds, global.server_sockets, timeout);

Step by step execution in gdb inside poll() have somehow unfrozen the
process at least once.

Any advice on what might be the issue here?

There are no issues with the HDDs (or so it seems; nothing in dmesg, and
SMART health assessment is "All OK").
I haven't tried to restart the server as it's really unwelcome (and I
doubt it's a proper solution).
I've also did "make -j8 buildworld" to see if there might be RAM issues
(as buildworld usually crashes on faulty RAM). No problems, either.

Thanks in advance.

P.S. Please CC, I am not subscribed to this list.

Kamigishi Rei

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 479 bytes
Desc: OpenPGP digital signature
Url : http://lists.freebsd.org/pipermail/freebsd-questions/attachments/20110122/be5d3a6d/signature.pgp

More information about the freebsd-questions mailing list