a new hard-drive in a 2y/o laptop

Ian Smith smithi at nimnet.asn.au
Sun Jan 2 15:16:10 UTC 2011

On Sun, 2 Jan 2011 10:22:55 +0000, Bruce Cran wrote:
 > On Fri, 31 Dec 2010 01:13:57 -0500
 > Chris Brennan <xaero at xaerolimit.net> wrote:
 > > No worries on missing it, I'm not sure that helped, I farted around
 > > with it again earlier today with little more in the way of success.
 > > What I tried was to just set up '/' and swamp and it still prompted
 > > me about not being able to find /dev/ad4s1b.
 > See my post later in the thread: this most likely has nothing to do
 > with the partition layout but the fact that FreeBSD is finding an old
 > partition scheme.

Even dodgier than waiting to quote a message from a digest that hasn't 
arrived yet is hand-indenting a paste from pipermail :) but I'll hang 
this off your thread, thanks Bruce ..

 > > On Sun, 02 Jan 2011 01:39:13 -0500
 > > Michael Powell <nightrecon at hotmail.com> wrote:
 > > "Unable to find device node for /dev/ad4s1b in /dev! The creation of 
 > > filesystems will be aborted." Then pressing "OK" brings this:
 > > "Couldn't make filesystems properly. Aborting."
 > > 
 > > This from sysinstall and occurs after fdisk, labeling, at the point
 > > when sysinstall then tries to write out the config to the disk and
 > > newfs.
 > This can happen if you've had it partitioned using GPT at some point 
 > - in that case you need to use dd to zero the first _and_ last 
 > sectors of the disk.

Although it's a brand new disk, quoting Chris' original message after 
skipping the shutdown when too hot issue:

 > gonna let it cool down and try the smart tests again. Incidentally, I 
 > was able to boot a gentoo disc and set up an ext4 filesystem on the 
 > same disk and it worked fine, so I don't understand why freebsd can't 
 > preform a newfs on the drive.

Hmm, should we bet against a gentoo install using GPT these days?

Finding out about the actual disk layout in gpt(8), gpart(8) etc proving 
fruitless and finding nothing in Handbook, FAQ or wiki, I resorted to 
http://en.wikipedia.org/wiki/GUID_Partition_Table for hopefully correct 
information.  I hadn't even known that sectors 1-33 were used for the 
GPT (making Mike's zeroing of sector 1 sensible even on sliced disks), 
nor that the last 33 sectors were for its backup table, thanks.  So:

 dd if=/dev/zero of=/dev/da4 skip=N

where N is the known total number of sectors minus 34, should do it?

If not, we can't rule out Mike's concerns about BIOS incompatibility 
or such, but this sure sounds like the next thing Chris should try.

cheers, Ian

More information about the freebsd-questions mailing list