Rem P Roberti remegius at
Sun Feb 13 17:53:34 UTC 2011

On 02/13/11 09:01, Robert Huff wrote:
> Rem Roberti writes:
>>   This is a new one for me.  I decided to do a manual update on my
>>   8.1 box, starting with csup.  Buildworld went fine, as did
>>   buildkernel.  However, when I tried to install the new kernel
>>   installkernel choked with an error message telling me that it
>>   could not proceed because the root partition was full.  What!  I
>>   did a df and sure enough the root partition was overloaded.  When
>>   I installed the system I used sysinstalls recommended sizes for
>>   the root partion, which is around 10G.  Anyway, when I rebooted,
>>   the system rebooted into single user mode, and that is presently
>>   where I stand.  I have no idea how to proceed at this point, and
>>   would appreciate any help in fixing this.  Of course, I smell a
>>   newbie type error in all of this, but haven't quite figured out
>>   where I went wrong.
> 	Start with this:
> 	du -x / | sort -nr | head -n 30
> 	This will give you the largest directories; if any of them
> don't look right - investigate further.
> 	(For comparison: the root directory on this machine is 2
> gbytes, of which I use 1.1.  10 gbytes is a lot of space

I completely misspoke, having confused the hard drive in question with 
another box. This drive is a 40G drive, of which 500MB was allotted for 
root.  When I ran your command I noticed the /boot/kernel.old was very 
large, so I moved the whole thing over to my home directory, which 
finally allowed me to boot the computer normally.  This was an intuitive 
move, and probably not that kosher, but it worked.  But where do we go 
from here?


More information about the freebsd-questions mailing list