why newline scape sequence does not work in Freebsd's bash

Erik Trulsson ertr1013 at student.uu.se
Sat Dec 31 02:10:11 UTC 2011

On Fri, Dec 30, 2011 at 06:47:45PM -0800, Edward Martinez wrote:
> On 12/30/11 17:06, ??????? ???????? wrote:
> > I used ' singe quotes, so double quotes is:
> >
> > $ FRUIT_BASKET="apples oranges pears"
> > $ echo -e "My fruit basket contains: \n $FRUIT_BASKET"
> > My fruit basket contains:
> > apples oranges pears
>     Thanks for the help, it worked. I find it interesting that FreeBSD's 
> echo man page does not mention the -e option is needed  to
>      enable  backslash escapes. I   remembered  why it worked on linux 
> is because i created an  echo alias with the -e option.
>      So i will do the same for FreeBSD.

The echo(1) manpage on FreeBSD doesn't say anything about '-e' because
that version of echo doesn't have such an option.
The echo you were actually using is the one builtin into bash and
is described in the bash(1) manpage (including mention of the -e

<Insert your favourite quote here.>
Erik Trulsson
ertr1013 at student.uu.se

More information about the freebsd-questions mailing list