Nuxeo install in FreeBSD

Bruno Gruel b.gruel at
Thu Dec 8 21:41:04 UTC 2011

 On Tue, 06 Dec 2011 20:50:06 +0100, Peter Ulrich Kruppa wrote:
> Hello Bruno,
> On 05.12.2011 21:47, Bruno Gruel wrote:
>> Hello,
>> I just want to know if someone already try to install NUXEO on a 
>> FreeBSD.
>> I try some month later without sucess. I will try to install it on
>> FreeBSD82 to day.
> For the fun of it I just tried the nuxeo-dm-5.4.2-tomcat package on
> my FreeBSD 9.0-RC1 (which in this case shouldn't make a difference to
> your 8.2) with jdk-1.6.0_03-p4.
> I unzipped the thing in /usr/local and tried to execute the
> ./bin/nuxeoctl start
> command, which failed. Having a look at the first line of this file I 
> found
> #!/bin/bash
> But my bash is installed in
> # which bash
> /usr/local/bin/bash
> So I changed the first line of nuxeoctl into
> #!/usr/local/bin/bash
> and now I can start and run Nuxeo.
> I hope that helps
> Peter.

 Sorry for the delay i can't do the test before.

 So i installed a 32 bits FreeBSD 82.
 Install JDK16 (who take a long time to compil)
 Install LibreOffice
 Install PDFtoHML
 Install postgresql

 unzip nuxeo-dm-5.4.2-tomcat in /usr/local

 Configure nuxeo via the web interface NB: after the configuration nuxeo 
 may do a self reload but it's never do it so after 10mins (have you got 
 the same behavior ) i restart the nuxeo server

 When i do a ./nuxeoctl start i got this

 Nuxeo# ./nuxeoctl start
 Launcher command: /usr/local/bin/javavm 
 -Xms512m -Xmx1024m -XX:MaxPermSize=512m 
 -Dsun.rmi.dgc.server.gcInterval=3600000 -Dfile.encoding=UTF-8 -Djava.awt.headless=true 
 -Dnuxeo.log.dir=/usr/local/nuxeo-dm-5.4.2-tomcat/log -jar 
 /usr/local/nuxeo-dm-5.4.2-tomcat/bin/nuxeo-launcher.jar start
 javavm: warning: The use of 'javavm' as a synonym for 'java' is 
 Nuxeo home:          /usr/local/nuxeo-dm-5.4.2-tomcat
 Nuxeo configuration: /usr/local/nuxeo-dm-5.4.2-tomcat/bin/nuxeo.conf
 Include template: /usr/local/nuxeo-dm-5.4.2-tomcat/templates/common
 Include template: /usr/local/nuxeo-dm-5.4.2-tomcat/templates/default
 Include template: /usr/local/nuxeo-dm-5.4.2-tomcat/templates/postgresql
 Detected Tomcat server.
 Configuration files generation (nuxeo.force.generation=true)...
 Configuration files generated.
 Sent server start command but could not get process ID.
 = Nuxeo EP Started
 = Component Loading Status: Pending: 0 / Unstarted: 0 / Total: 453
 Started in 0min28s

 When i try to connect myself to ip:8080 i got this tomcat error:

 HTTP Status 404 -

 type Status report


 description The requested resource () is not available.
 Apache Tomcat/6.0.20

 So what is my mistake ?? did you do something else ??


 Sallanches Data Network (SDN)
 Pour l'Internet des internautes

More information about the freebsd-questions mailing list