drivin' me nuts: permissions and cdda2wav

Ronald F. Guilmette rfg at tristatelogic.com
Tue Dec 6 11:22:48 UTC 2011

With a pre-recorded CD in the drive, the following works fine for me when
I'm root:

    cdda2wav -D 0,0,0 -B

My question is:  What do I need to do in order to make this work also
when executed from a non-root account?

Here's what I get when I try to do the above from a non-root account:

  cdda2wav: Permission denied. Cannot open or use SCSI driver.
  cdda2wav: For possible targets try 'cdda2wav -scanbus'. Make sure you are root.
  Probably you did not define your SCSI device.
  Set the CDDA_DEVICE environment variable or use the -D option.
  You can also define the default device in the Makefile.
  For possible transport specifiers try 'cdda2wav dev=help'.

Effing hell!  I've tried just about everything I can think of off the top
of my head to beat this and nothing works.  I've tried chmod 0660 /dev/pass*
(and yes, the account I'm trying these experiments from _is_ a member of the
`operator' group), but that didn't help a bit.

And before anybody asks, let me say that yes, I _do_ have:


in my /boot/loader.conf file.

So how exactly does one adjust the permissions on one of these atamicam
pseudo-SCSI devices.  Where are they underneath /dev ?  Please excuse my
ignorance, but I just don't know.

<<gnashing of teeth sound>>

All I really wanted to do is to rip an "E"CD (enhanced CD) that I own,
using abcde.  I found out that cdparanoia chokes on the ECD, so I'm trying
to figure out how to make abcde work with cdda2wav, but it apparently isn't
at all easy.  (Any hints or advice welcomed.)

Oh!  And by the way, this causes a segfault and a core dump:

  cdda2wav -D /dev/acd0 -B

I'll have to send in a PR on that, I guess, but it is rather stunning to me
that nobody even tested for that.


More information about the freebsd-questions mailing list