System hanging, error messages with USB drive on FreeBSD 8.1

Polytropon freebsd at
Sun Aug 28 06:01:30 UTC 2011

On Sat, 27 Aug 2011 17:01:24 -0600, Brett Glass wrote:
> I'm working with a FreeBSD 8.1-RELEASE/amd64 machine that's 
> attempting to write data to an ordinary Kingston 8 GB microSD card. 
> The card has been inserted into its USB adapter and plugged into a 
> USB port on the machine. The system is locking up repeatedly with 
> messages that say
> (da1:umass-sim1:1:0:0): SYNCHRONIZE CACHE(10). CDB: 35 0 0 0 0 0 0 0 0 0
> (da1:umass-sim1:1:0:0): SCSI sense: Error code 0x52
> A Web search reveals that problems like this have cropped up for 
> many, many FreeBSD users as far back as 4.x. But I can't seem to 
> find any solution (which amazes me; if there's a bug, one would 
> think it would have gotten some attention). Do I have to abandon 
> the use of FreeBSD with USB thumb drives (or maybe with USB 
> altogether)? Hope not, but I may have to if I can't get this fixed.

I'm not sure if this will help you, but I also had similar
problems with a Kingston USB stick (normal storage stick,
no removable microSD card). It didn't work on any of my
FreeBSD systems. So I finally returned it to the shop and
got a Sony USB stick instead - no problems, works fine.

So this is my assumption: Some hardware vendors maybe
improperly implement the USB protocol in their devices,
so any OS requiring standard conformation of the attached
devices (which are malfunctioning according to the USB
protocol specifications) signals an error.

I also have a "multi card reader" (CF, SD, microSD and
who knows what else, it's a "hama USB 2.0 Card Reader
35 in 1") which attaches per USB. It also does not work
properly (also causes, at least when I tried it the last
time on a 7-STABLE system). The built-in card reader of
my home PC works fine instead.

Recently, I had to access the USB stick of a friend. The
stick didn't work at first try, and the friend told me to
try multiple times; he stated that he would have to do that
on his Linux system too. So I tried a second time - and
magically, the stick worked as intended.

Maybe this approach can help here too?

But when you say that attaching the USB adaptor causes the
system to _hang_, this means that the OS detected a severe
hardware malfunction. The OS doesn't stop for no reason; it
does so in order to prevent further damages. This behaviour
is intended.

What's _not_ intended is hardware manufacturers poorly caring
for the implementation of the "software part" in their storage
devices. Sadly that's not a typical sign of "el cheapo" stuff
anymore - even expensive devices sometimes suffer from that
poor quality, i. e. their _customers_ are suffering. :-(

So if you have problems with such hardware, returning it is
an option, and then try some different brand or model. It
helps if you print out a dmesg report - looks exceptionally
good when done on green-bar paper :-) - and use a red marker
to highlight the USB related error messages. Then just say:
"This USB adaptor is broken." No average salesman will disagree,
and you should immediately get your money back. I've tried
that, it works fine. :-)

Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...

More information about the freebsd-questions mailing list