upgrade of portupgrade to 2.4.9,2

Andréas Berg freebsd at a-berg.se
Tue Aug 23 09:42:06 UTC 2011


This ruby+portupgrade upgrade seems to be quite a mess. My systems
fetch new ports tree nightly and I upgrade during the day when I have
some spare time. 

So, this morning my systems had the new ruby versions
and the UPDATING instruction, but not the new portupgrade port version
(not that it had helped, but anyway). So, portupgrade -fr lang/ruby18

Right now, I've got one system (the less critical one)
upgraded with the latest and portupgrade is still failing. The other I
backed down to ruby18 and portupgrade-2.4.8_1,2 and that works.

Information from the upgraded system:

# pkg_info -Ia | egrep
portupgrade-,2 FreeBSD ports/packages
administration and management tool s
ruby-,1 An object-oriented
interpreted scripting language
ruby19-bdb-0.6.6 Ruby interface to
Sleepycat's Berkeley DB revision 2 or lat

Here's an example failure
output. I get the same errors whatever port I try to upgrade..

portupgrade -f portupgrade-,2
---> Session started at: Tue, 23
Aug 2011 11:10:02 +0200
---> ** Upgrade tasks 1: 0 done, 0 ignored, 0
skipped and 1 failed
---> Listing the results (+:done / -:ignored /
*:skipped / !:failed)
 ! ports-mgmt/portupgrade
(portupgrade-,2) (can't modify frozen string)
---> Packages
processed: 0 done, 0 ignored, 0 skipped and 1 failed
---> Saving the
results to '/var/log/portupgrade.results'
** Failed to save the results:
undefined method `install_data' for #
---> Session ended at: Tue, 23 Aug
2011 11:10:08 +0200 (consumed 00:00:05)



On Tue, 23
Aug 2011 11:00:48 +0200, Andrea Venturoli wrote: 

> On 08/23/11 09:58,
Stanislav Sedov wrote:
>> On Sun, 21 Aug 2011 15:18:28 +0200 Andrea
Venturoli mentioned: 
>>> On 08/21/11 08:26, n dhert wrote: 

>>>> I did a portupgrade on a freebsd 8.2-RELEASE of the portupgrade
program itself portupgrade-2.4.8_1,2< needs updating (index has 2.4.9,2)
(that upgraded also ruby to 1.9:
>>> I did the same on some boxes and
I'm having a lot of troubles too... # pkgdb -L Look for lost
dependencies: undefined method `map' for #
>> Hi! Can you, please, try
the portupgrade version from the ports? It should fix those issues.
Not really.
> I tried "portupgrade -R portupgrade", but still had a
messed-up system.
> Since I don't use Ruby for much and had only
portupgrade and libchk 
> using it, I wiped them all and reinstalled
portupgrade from scratch. 
> This also reinstalled ruby.
> I'm still
getting "undefined method `map'..." when I run pkgdb, however.
>> #
pkg_info -r portupgrade* Information for portupgrade-,2: Depends
on: Dependency: libyaml-0.1.4_1 Dependency: openssl-1.0.0_5 Dependency:
pkg-config-0.25_1 Dependency: libffi-3.0.9 Dependency:
> Sorry for the inconvinences! 
> You're welcome, I
appreciate your work and help.
> bye & Thanks
> av.
freebsd-questions at free> freebsd.org/mailman/listinfo
> tions To
unsubscribe, send any mail to "freebsd-questions-unsubscribe at freebsd.org


[1] mailto:ml at netfence.it
mailto:freebsd-questions-unsubscribe at freebsd.org

More information about the freebsd-questions mailing list