ipmi is broken? (ppc0: cannot reserve I/O port range)

Fravadona rnavaza at hotmail.com
Fri Aug 5 16:28:01 UTC 2011

Actually IPMI was working until yesterday (on Linux rhel 5) and stopped
working when I installed FreeBSD 8.2 amd64 (same result with FreeBSD 8.2

On Linux : 
# dmidecode
Handle 0x0029, DMI type 38, 16 bytes
IPMI Device Information
	Interface Type: KCS (Keyboard Control Style)
	Specification Version: 1.5
	I2C Slave Address: 0x10
	NV Storage Device: Not Present
	Base Address: 0x0000000000000CA2 (I/O)

# ipmitool mc info
Device ID                 : 0
Device Revision           : 1
Firmware Revision         : 1.48
IPMI Version              : 1.5
Manufacturer ID           : 2
Manufacturer Name         : Unknown (0x02)
Product ID                : 34869 (0x8835)
Product Name              : Unknown (0x8835)
Device Available          : yes
Provides Device SDRs      : no
Additional Device Support :
    Sensor Device
    SDR Repository Device
    SEL Device
    FRU Inventory Device
    IPMB Event Receiver
    Chassis Device
Aux Firmware Rev Info     : 

02:01.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5704 Gigabit
Ethernet (rev 03)
02:01.1 Ethernet controller: Broadcom Corporation NetXtreme BCM5704 Gigabit
Ethernet (rev 03)

As my google searches pointed to me, the problem on FreeBSD seems to be
related to the bge driver.
I tried to configure hw.bge.allow_asf=0|1 and hw.pci.enable_msi=0 in
loader.conf, which didn't fix the problem.
Should I try to compile an older bge driver or fix the new one ?

View this message in context: http://freebsd.1045724.n5.nabble.com/ipmi-is-broken-ppc0-cannot-reserve-I-O-port-range-tp4266087p4670031.html
Sent from the freebsd-questions mailing list archive at Nabble.com.

More information about the freebsd-questions mailing list