USB disk on CS5536 unstable

Anselm Strauss amsibamsi at
Thu Sep 30 19:33:41 UTC 2010

Maybe sending it to just the USB list was too specific ...

On 09/30/10 00:08, Anselm Strauss wrote:
> Hi
> I have an ALIX board that has an AMD Geode and the CS5536 companion chip
> with integrated USB on it. When I connect a USB disk I have observed
> various problems. For example when I run fsck_ufs on a 250 GB partition
> the process gets stuck in biord state and fsck reports unreadable
> sectors. When I do a dd over the whole disk and direct it to /dev/null
> it suddenly returns with no error, but having read only a small fraction
> of the disk. I tried it with two different disks and two different ALIX
> boards. I'm pretty sure the disks are okay since I tried them on other
> hardware.
> As far as I know there was some trouble with the chip regarding
> timeouts. Under load after some time the USB just stops responding. I
> have tried 8.0 and 8.1. Is there any known problem? How can I track this
> down?
> Anselm

More information about the freebsd-questions mailing list