pkg_config Version Numbers

Dan Nelson dnelson at
Wed Sep 29 20:56:26 UTC 2010

In the last episode (Sep 29), Martin McCormick said:
> 	I built bind9.7.1 on a 64-bit FreeBSD system and then
> did make package-recursive in order to produce a package that
> can be installed on some other systems. After doing so, I get
> the following warning on numerous other packages when I install
> them.
> pkg_add: warning: package pkg_name' requires 'pkg-config-0.23_1', but
>  'pkg-config-0.25' is installed
> 	This looks like it could be harmless enough as pkg-config-0.25
> is newer but I thought I would ask before creating any more
> possible monsters. Is this something to fix or can I forget it?

You can probably ignore it.  Your build system had some out-of-date
installed software, so your package has dependencies on software versions
that don't exist on newer systems.  Make sure that the binaries you're
installing weren't linked with any out-of-date shared library versions,
though.  That'll cause runtime linker errors when you try and run affected

	Dan Nelson
	dnelson at

More information about the freebsd-questions mailing list