Problems upgrading p5-IO-Compress

Ron rg.lists at
Sun Sep 26 16:59:34 UTC 2010

I went to upgrade my ports this morning and saw this:

p5-Compress-Zlib-2.015      <  needs updating (port has 2.030) (=> 'archivers/p5-IO-Compress')
p5-IO-Compress-Base-2.015   <  needs updating (port has 2.030) (=> 'archivers/p5-IO-Compress')
p5-IO-Compress-Bzip2-2.015  <  needs updating (port has 2.030) (=> 'archivers/p5-IO-Compress')
p5-IO-Compress-Zlib-2.015_1  <  needs updating (port has 2.030) (=> 'archivers/p5-IO-Compress')

After reading CHANGES and UPDATING I did a portupgrade p5-* since there were no specific instructions and I get this:

===>  Checking if archivers/p5-IO-Compress already installed
===>   An older version of archivers/p5-IO-Compress is already installed (p5-Compress-Zlib-2.015)
      You may wish to ``make deinstall'' and install this port again
      by ``make reinstall'' to upgrade it properly.
      If you really wish to overwrite the old port of archivers/p5-IO-Compress
      without deleting it first, set the variable "FORCE_PKG_REGISTER"
      in your environment or the "make install" command line.
*** Error code 1

Stop in /usr/ports/archivers/p5-IO-Compress.
*** Error code 1

Stop in /usr/ports/archivers/p5-IO-Zlib.
** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade20100926-29184-lhtw7y-0 env UPGRADE_TOOL=portupgrade UPGRADE_PORT=p5-IO-Zlib-1.10 UPGRADE_PORT_VER=1.10 make
** Fix the problem and try again.
--->  Skipping 'archivers/p5-Archive-Tar' (p5-Archive-Tar-1.68) because a requisite package 'p5-IO-Zlib-1.10' (archivers/p5-IO-Zlib) failed (specify -k to force)
** Listing the failed packages (-:ignored / *:skipped / !:failed)
	! archivers/p5-IO-Zlib (p5-IO-Zlib-1.10)	(unknown build error)
	* archivers/p5-Archive-Tar (p5-Archive-Tar-1.68)

If I try and run pkg_delete p5-IO-Compress-Zlib-2.015_1 it won't let me because the package is in use. 

How do I upgrade?  Did I miss some obvious instructions?  All UPDATING says is:

  AFFECTS: users of p5-Compress-Zlib, p5-IO-Compress-*
  AUTHOR: mm at

  The p5-Compress-Zlib, p5-IO-Compress-Base, p5-IO-Compress-Zlib and
  p5-IO-Compress-Bzip2 ports have been replaced by p5-IO-Compress.
  Users of Perl 5.10 and higher do not need to install this module
  because it is already included in the standard perl distribution.

I tried following the instructions above about running make deinstall and now I get:

[Updating the pkgdb <format:bdb_btree> in /var/db/pkg ... - 238 packages found (-1 +0) (...) done]
Stale dependency: p5-Archive-Tar-1.68 --> p5-IO-Zlib-1.10 -- manually run 'pkgdb -F' to fix, or specify -O to force.

I've tried running pkgdb -F, but it is just asking my a lot of questions like:

Duplicated origin: archivers/p5-IO-Compress - p5-Compress-Zlib-2.015 p5-IO-Compress-Base-2.015 p5-IO-Compress-Bzip2-2.015 p5-IO-Compress-Zlib-2.015_1
Unregister any of them? [no]

and I have no idea what the right answer is.

I am running perl 5.8.9 and Freebsd 7.1

Any help is appreciated since I am completely lost.  I've been freebsd for many years on my personal server but never encountered a mess like this before.


More information about the freebsd-questions mailing list