The nightmarish problem of installing a printer

dan glimp at
Sat Sep 18 21:43:41 UTC 2010

On 17.09.2010 02:45, Chabane HEMDANI wrote:
>   I'm computer science teacher at university of Tizi-ouzou in Algeria. I'm
> using FreeBSD since 2007 when I "discover" it by chance when searching in
> the Web something about Linux.
>   Since that date, I always invited and recommended to my students to install
> and use this "magical" and my favorite system.
> However, all my students retort me that they have a problem of installing
> their printers. I have so this problem, so I can't tell good-bye
> definitively to winosor and Linux. I always need them for printing.
> I've search, read, learn, follow instructions about nearly all the
> web-documentation about installing a new printer to work under cups without
> any success. I've  an HP Laser Jet 1018 printer and tools given by package
> print/hplip don't work correctly.
> I'm using FreeBSD 8.1-RELEASE
> I've rebuild a kernel without  ulpt.
> I modified my /etc/rc.conf to enable cupsd and hpiod and  hpssd.
> I modified /etc/devfs.rules like suggested by cups (see pkg_info -D
> cups-base-1.4.4 ).
> I've made many other configurations like that suggested at
> <,_hplip%20>
> and finally, I've given to my students the wrong  answer that "no one can
> print under FreeBSD !"
> Please where is the problem?
> Please help me to help others.
> Please help me to enlarge the FreeBSD users community.
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"

Definitely, I am feeling very "lucky".

We have 2 multi-functional devices here.

1 - Samsung SCX-4100 .
Once I installed SPLIX and the CUPS "system", I manually added the 
device to CUPS (using SCX-4200 ppd file) and print 2-3 test pages. For 
the moment I have not tried scanning. (p.s. for printing, I tried first 
using lpd and the foomatic filter but the filtering process unexpectedly 
broke: probably a misconfiguration with foomatic or a bug in it).

2 - HP Photosmart C3180.
Once I installed HPLIP and adjusted some permissions I used a hp sw tool 
to update the CUPS printers' database (all with the __default__ 8.1 
kernel). I then Succesfully printed a test page and successfully tested 
the device as a scanner (blank scanning of the plate).

The "annoying" and computer-time-consuming part was recompiling gtk and 
qt with CUPS support, that was not the default when I first installed 
In the end, CUPS was also easy to use to share the 1st printer in our 
small and simple network.

To close, a sincere thank you to all the people directly/indirectly 
involved in all the branches (mailing lists too :-) ) of this project.


More information about the freebsd-questions mailing list