virtaullBox AMD64 32bit lib

Gholam Mostafa Faridi mostafafaridi at
Thu Sep 16 14:14:41 UTC 2010

On 09/16/2010 17:57, Pieter de Goeje wrote:
> chflags noschg /usr/lib32/
I do not know what happen , but after I run that command I can install 
virtulbox and it work bu when I want run it I see error about

Failed to create a new session.

Callee RC:

and I can not run it and use it ,
but when I run this command again
cd /usr/src ; make build32 install32 ; ldconfig -v -m -R /usr/lib32
  and I see this error

sh /usr/src/tools/ -o root -g wheel -m 444  crtend.o 
sh /usr/src/tools/ -o root -g wheel -m 444  crtbeginT.o 
sh /usr/src/tools/ -o root -g wheel -m 444  crtbegin.So 
sh /usr/src/tools/ -o root -g wheel -m 444  crtend.So 
===> lib/csu/i386-elf (obj,depend,all,install)
ld -m elf_i386_fbsd -Y P,/usr/obj/usr/src/lib32/usr/lib32  -o gcrt1.o -r 
crt1_s.o gcrt1_c.o
ld: Relocatable linking with relocations from format elf64-x86-64 
(gcrt1_c.o) to format elf32-i386-freebsd (gcrt1.o) is not supported
*** Error code 1

Stop in /usr/src/lib/csu/i386-elf.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.

I think my system is broken . how I solve this problem ?

More information about the freebsd-questions mailing list