virtaullBox AMD64 32bit lib

Gholam Mostafa Faridi mostafafaridi at
Wed Sep 15 08:18:19 UTC 2010

I want install virtualBox on AMD 64 and I use FreeBSD 8.1 and I have SRC 
directory , but when I run make install clean I see this error
" Requires 32-bit libraries installed under /usr/lib32.
Do: cd /usr/src; make build32 install32; ldconfig -v -m -R /usr/lib32 "
and I run this command
"cd /usr/src; make build32 install32; ldconfig -v -m -R /usr/lib32"
  and after minutes I see this error

"===> gnu/lib/csu (obj,depend,all,install)
sh /usr/src/tools/ -o root -g wheel -m 444  crtbegin.o 
sh /usr/src/tools/ -o root -g wheel -m 444  crtend.o 
sh /usr/src/tools/ -o root -g wheel -m 444  crtbeginT.o 
sh /usr/src/tools/ -o root -g wheel -m 444  crtbegin.So 
sh /usr/src/tools/ -o root -g wheel -m 444  crtend.So 
===> lib/csu/i386-elf (obj,depend,all,install)
ld -m elf_i386_fbsd -Y P,/usr/obj/usr/src/lib32/usr/lib32  -o gcrt1.o -r 
crt1_s.o gcrt1_c.o
ld: Relocatable linking with relocations from format elf64-x86-64 
(gcrt1_c.o) to format elf32-i386-freebsd (gcrt1.o) is not supported
*** Error code 1

Stop in /usr/src/lib/csu/i386-elf.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.
ldconfig: warning: /usr/lib32: No such file or directory "

I make post about this error in  freebsdforums but they can not help me
please see link

they said problem is ccache and I disable and remove ccache  ,but still 
I have that probelm
please help me

More information about the freebsd-questions mailing list