portupgrade -a stops at building gnome-menus

Michael D. Norwick mnorwick at centurytel.net
Sat Sep 11 23:52:10 UTC 2010


#>uname -a
FreeBSD ****@****.net 8.1-RELEASE FreeBSD 8.1 RELEASE FreeBSD 8.1-RELEASE
#0: Thu Aug 12 08:43:46 CDT 2010     
****@****.net:/usr/obj/src/sys/GENERIC i386

Running on VirtualBox Version 3.2.8 r64453 running on current Debian 
'lenny',  Pentium 4 2.4 GHz. 4G ram.
portsnap update on 09/08/2010.

Trying to do 'portupgrade -a',  initially had a portupgrade stop at 
'/usr/ports/graphviz'  an error about 'dot' and doxygen.  Built doxygen 
and graphiz from the individual /usr/ports/*** directories after 
'portsclean -DLP' and individual 'make clean' in the respective 
/usr/ports directories.  Had the "/usr/local/include/python2.6/pth.h 
link to /usr/local/include/pth/pth.h" issue.  Fixed that and portupgrade 
borked at building gnome-menus.  '/usr/bin/ld: cannot find -lpth'.  Did 
ln -s /usr/local/lib/pth/libpth.a /usr/local/lib/ and ln -s 
/usr/local/include/pth/pth.h /usr/local/include/python2.6/ - again.  Ran 
make install clean from /usr/ports/x11/gnome-menus after executing make 
clean.  Still no joy.
Yeah, I'm a 15 year linux guy, but, I've installed and used FreeBSD 
around the 5.0-RELEASE days so I don't think I'm totally clueless.  I'm 
running it as a virtual machine because I would like to install it on a 
new machine once I get past the test drive and checkout.
Tried to build a new kernel a week or two ago and that went awry.  
Deleted the VM and reinstalled from the RELEASE dvd.iso.
What am I doing wrong?

Michael D. Norwick

PS: I've R.T.F.M'd and Googled.  Filed a bug report on the graphviz 
issue but now I don't think it was a problem with the graphviz build.

More information about the freebsd-questions mailing list