Failure to use Adaptec 2405 with FreeBSD 8.1

Torbjorn Granlund tg at
Sun Sep 5 13:18:03 UTC 2010

I am trying to get an Adaptec 2405 to work in *any* mode with FreeBSD
8.1.  I have installed FreeBSD hundreds of times, usually quiet

I have just one disk, a Seagate Savvio 15k 146 GB SAS.  (The reason I
use a RAID controller is that it appears that FreeBSD does not support
any plain SAS controllers.)

I have tried configuring the controller for JBOD, and many types of
RAID modes.

In all tried RAID modes, FreeBSD's installation program allows me to put
FreeBSD on the disk.  When I reboot, the system hang or crashes during
initial kernel load.  (Whether it hangs or crashes seem to depend on the
size of created partitions, and other such magic.)

I then boot things in "fixit" mode.  I can then newfs any partition
without problems.  I can also mount any newly newfs'ed partition except
the first one on the disk.  You read it right, newfs succeeds but then
the partition cannot be mounted.  That strange behaviour seems
reproducible with any sort of array configuration.

Finally, I gave up array configs.  After all, I have just one disk, so
any array is somewhat degenerate.  And even if I could get it to appear
to work, I wouldn't want to put my files on a disk subsystem that seems
very buggy.

In JBOD mode, FreeBSD's installation program does not allow installation
to the disk.  (As a sanity check of the hardware and firmware, I tried
installing Debian GNU/Linux, and it works.  Using Debian is not an
option, I need FreeBSD.)

I again start fixit mode to check dmesg.  And the disk is really
there!  It shows up as a "Fixed Uninstalled SCSI 5" disk.  The
/dev/aac* devices are in place.

I am stuck at this point.  I have tried google for help.  I have read
some FreeBSD kernel sources.  I have no idea why FreeBSD rejects
installation to the disk, and what FreeBSD means with that the disk is

System summary:

Controller:	Adaptec 2405 RAID SAS PCIe
Disk:		Seagate Savvio 15k 146 GB SAS
Motherboard:	ASUS M2V-MX AM2 MicroATX PCIe
FreeBSD ver:	8.1


* Can Adaptec 2405 actually be used as a boot device with FreeBSD?

* Is the firmware and/or FreeBSD drives for 2405 in such a shape that it
  can be trusted for a critical system?  Are my problems due to bugs, or
  am I trying something that is not (yet) supported.

* If Adaptec 2405 is not good with FreeBSD, what controller should I
  purchase instead, to allow me to use the new disk?  (I do not care
  about RAID.)


More information about the freebsd-questions mailing list