GPT Question

Derek Funk dfunk6 at
Thu Nov 11 23:45:23 UTC 2010

On 11/10/2010 9:34 PM, Mark Caudill wrote:
> Hash: SHA1
> Firstly, hello list. This is my first post here and while I'm a long
> time Linux user, I'm a recent FreeBSD convert so please bear with me.
> Yesterday I installed an extra hard drive that used to be in a Windows 7
> box. In sysinstall I ran fdisk then label to try to get the disk ready.
> The problem was that even though after I hit 'w' and it didn't give any
> errors, when I did a `ls /dev/ad*` it was still showing the old
> partitions, even after a reboot. I tried running fdisk manually and a
> few other things I found on Google but they all seemed to just be
> silently failing since they never showed an error but the changes never
> really went into effect. When I was first building out this box I had an
> issue partitioning the disks but the behavior was different in that it
> errored with messages about not being able to commit or write the
> changes to disk. That issue turned out to be with some GPTs on the drive
> which I was able to remove in Linux with parted. Anyway, I figured that
> there was a chance that this might be a GPT issue since this drive came
> form the same machine as the other. I couldn't remember what command I
> had run and didn't feel like pulling the drive into another machine so I
> just ran `dd if=/dev/zero of=/dev/ad12 bs=512` and let it run. That must
> have done the trick because I was then able to partition the disk in
> sysinstall and all is well. What I'm wondering is what really went on
> here? I'm not clear at all as to why FreeBSD (or some mechanism within
> this installation) isn't able to handle this. Or was this a GPT issue at
> all? I'd like to find out what was going on so that I don't chase my
> tail again on issues like this in the future. Thanks.
> Version: GnuPG/MacGPG2 v2.0.16 (Darwin)
> Comment: Using GnuPG with Mozilla -
> iQIcBAEBAgAGBQJM22Q5AAoJEB/pNtMYu8Pl8G4P/RyHfn03BxY0tSaii2J1a5gQ
> L7q7ZK9mrvpXCv/tGk+ieWwct01cgpf3SRoEbmjpnL4c//g54fChCdOylJDD7wpU
> OoYrjKjosz5juqkqS0Ty930KCcWRX5DYLsBH0QSHg7q+9ZNnFBuNIB0os4DyZ803
> rmxg0bz4YDzTHFe7sJG1/uhN1gUGT3jGUuXUEKnKIrZQaUvdJe3xfNtq/mqHKiZG
> il45ljdxESt/Y9p7MyGle439YM/BtFt48+O9vcbd0Oljl+nwlFVHNPMKd91KOv/b
> WPd8y1wmO2X7tTUetDqjby3GlRjvpuPrzddfbpj87DqKdvJ3hqGtGRflrMeWLklg
> dAS5n3Q8x42vu/5CXlCWtNO2GQMYWTX7VPWmCzymzC60A3YM4UoY3GEF7PV/tChS
> etUVcSp3JhpepOjgVyY7SA+dO3sZhLAvulqhy/KX6E1ffkCoRMPYWdu9zYXk1F/i
> 6tEpEDdU7QAViCSbUnp7ZZrt/QcG5XbD0yOUy1M/bvfkGo3qd+TukTCJ8s0JDZ8x
> lPYF+p8pkzm9zfFeA1e90VqkkhNb/gDFzwg3grcO5hEse4OXlsXMmA5kfxjVKbFj
> mUO0LYyMmd0QW49J91ts
> =w5P4
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"
My understanding is, if you are using FreeBSD 8.x, sysinstall / fdisk 
will not write disk partitions.  gpart is used now.

More information about the freebsd-questions mailing list