CPIO compatibility with Freebsd 8[.1]

Pico Geyer picogeyer at gmail.com
Wed Nov 10 12:22:58 UTC 2010

Hi all.

I recently noticed that I could not extract a cpio archive that I have
on my Freebsd 8.0 machine.
I thought that the archive might be corrupt so I compared the md5sum
to a backup that I have and it was fine.

I then tried to extract the archive on Freebsd 7.2 and it extracted
without problems.
I then tried on a Freebsd 8.1 system and I get the errors again.

My archive is actually the output of a nanobsd build that someone
created for me.
So as root I do
> cpio -i < ../_.fsimg

And as the output shows it can't create many files.
usr/local/lib/python2.6/distutils/tests/__init__.py: Can't create
usr/local/lib/python2.6/distutils/tests/__init__.pyo: Can't create
usr/local/lib/python2.6/distutils/tests/__init__.pyc: Can't create
usr/local/lib/python2.6/distutils/tests/support.py: Can't create
usr/local/lib/python2.6/distutils/tests/support.pyo: Can't create
usr/local/lib/python2.6/distutils/tests/support.pyc: Can't create

Does anyone know why this might be happening?
Are there compatibility changes with cpio?

Any advice would be appreciated.

More information about the freebsd-questions mailing list