portupgrade fails to run or do anything

Ron (Lists) rg.lists at rzweb.com
Sun Nov 7 18:05:57 UTC 2010

On Sun, 7 Nov 2010 12:57:03 -0500, Chris Brennan <xaero at xaerolimit.net>
> On Sun, Nov 7, 2010 at 12:21 PM, Ron (Lists)  wrote:
>  I'm trying to upgrade my ports and I can't get portupgrade to do
> anything.  I type 'sudo portupgrade apache' (or any package) and all
> I get back is a command prompt.  No error or any other message.
>  portversion seems to work correctly, showing my out of date ports,
> etc.
>  Running portupgrade with -F doesn't help at all.  I've also noticed
> that tab-expansion isn't working like it used to on the port names, so
> that makes me wonder if the database is screwed up.  I've tried
> running pkgdb and it just returns like portupgrade.  Running portsdb
> to try and rebuild the index doesn't help.
>  Any ideas?  I'm perplexed and Google is no help.
>  Thanks
> Syntax is 'portupgrade www/apache' (/usr/ports is assumed)

'portupgrade apache' has always worked before and adding the www/ in
front does not fix the problem.  Still the same results, e.g. nothing. 


More information about the freebsd-questions mailing list