Kernel panics?

Richard Morse remorse at
Thu Nov 4 12:04:39 UTC 2010

Hi! I'm having a problem with an 8.1-RELEASE #0 amd64 machine.

Three weeks ago, it had a kernel panic, which I was too tired to properly capture. On reboot, I forgot to run fsck in single user mode; about 12-14 hours later it crashed complaining that the background file system checks were inconsistent.

A day later it crashed with a "server double fault"; I was unfortunately on the way to a meeting, along with all of my technical co-workers, so I wasn't able to see the screen, and it was being reported by someone who was poorly equipped to give a good report.

A few days later, it had hung (it didn't respond to input), and I needed to hard restart.

A few days later, the same thing happened.

Last weekend, on Friday evening it complained about the hard disk controller disappearing (at least, as far back as I was able to go in the screen buffer).

Saturday night, I finally got a kernel panic that I captured; after this, I turned on core dumps.

However, last night, it crashed again, and tried to write out a core, but didn't succeed.

The kernel panic from Saturday night was:

    panic: unknown cluster size
    cpuid = 0
    Uptime: 1h49m37s
    Cannot dump. Device not defined or unavailable.
    aac0: shutting down controller...
    Fatal trap 12: page fault while in kernel mode
    cpuid = 9; apic id = 10
    fault virtual address = 0x1d
    fault code            = supervisor write data, page not present
    current process       = 12 (irq256: em0)
    trap number           = 12

Last night's:

    Fatal trap 12: page fault while in kernel mode
    cpuid = 9; apic id = 11
    fault virtual address = 0x8098f90e
    fault code            = supervisor read data, page not present
    current process       = 97530 (taper)
    trap number           = 12
    panic: page fault
    cpuid = 9
    Uptime: 3d21h24m57s
    Physical memory: 12211MB
    Dumping 2942MB:

Note that there was nothing after the "Dumping 2942MB:"; the cursor was sitting just after the colon. On reboot, it did not find any cores to save to disk (I did have to boot single user and fsck -y; is it possible that this interfered with the core dump? if so, how do I fix this?).

I tried, this morning, to run memtest86, however both 3.5 and 3.4 just give loud annoying beeps, not displaying anything on screen (not even a menu; once I get past the boot loader from the memtest86 cd, it just starts beeping).

Any suggestions?


The information in this e-mail is intended only for the person to whom it is
addressed. If you believe this e-mail was sent to you in error and the e-mail
contains patient information, please contact the Partners Compliance HelpLine at . If the e-mail was sent to you in error
but does not contain patient information, please contact the sender and properly
dispose of the e-mail.

More information about the freebsd-questions mailing list