FreeBSD Doesn't "See" Crucial C300 SSD on Marvell Controller

Dan Olson danolson100 at
Mon Nov 1 23:26:48 UTC 2010

On 11/1/2010 7:12 AM, Jud wrote:
> The old desktop gave up the ghost after many years of use (memory
> problems plus a hard drive with an increasing number of bad sectors),
> and I've just finished putting together a new one.  Win7 x64 and Ubuntu
> amd64 are running on it, and I would dearly love to install FreeBSD.
> Hardware is an ASUS Rampage III Formula motherboard with a Crucial C300
> 256GB SATA 6GB/s-capable SSD connected to one of the motherboard's two
> internal SATA 6GB/s ports.  These two ports use a Marvell 88SE9128
> onboard chip as the controller.  The controller is supposed to support
> (hardware) RAID, but of course with one drive I am using it in "normal"
> non-RAID mode.  (To say this particular controller chip has a
> problematic reputation at the moment is a bit of an understatement.
> I've personally seen some weirdness, including the Crucial drive not
> showing up in the BIOS boot priority menu a time or two.  Nevertheless,
> as I said Winders and Ubuntu are running and I'm really looking forward
> to having my favorite OS on my new box.)  I also have two Hitachi
> Deskstar drives and a USB stick.
> I tried the October amd64 DVD snapshot of -CURRENT from the snapshots
> page, guessing it would have the latest hardware support.  The DVD boots
> into the installer, but sysinstall only shows me the Deskstars and the
> USB stick as options to install to.
> Puttering around the lists trying to find something that has any chance
> of being relevant, I ran across this excerpt from a post to the
> freebsd-current list in October:
> ****************************************************************************
>>> In an attempt to get more information about this issue, I'd like to ask
>>> people on freebsd-current if they're using any Sandforce-based SSDs with
>>> FreeBSD. So far, it appears not a lot of people do, making it hard to
>>> debug this issue (
>> MCP5x SATA are not the best controllers for compatibility testing. They
>> have enough problems on their own, even without Sandforce.
>> When you tested Marvell, have you tried to use mvs(4) driver?
> No, I only tried to use ata(4). I tried using mvs(4) now, and that
> works!
> mvs0:<Marvell 88SX6081 SATA controller>  port 0x4000-0x40ff mem
> 0xb0100000-0xb01fffff irq 11 at device 2.0 on pci1
> mvs0: Gen-II, 8 3Gbps ports, Port Multiplier supported
> mvsch0:<Marvell SATA channel>  at channel 0 on mvs0
> mvsch1:<Marvell SATA channel>  at channel 1 on mvs0
> mvsch2:<Marvell SATA channel>  at channel 2 on mvs0
> mvsch3:<Marvell SATA channel>  at channel 3 on mvs0
> mvsch4:<Marvell SATA channel>  at channel 4 on mvs0
> mvsch5:<Marvell SATA channel>  at channel 5 on mvs0
> mvsch6:<Marvell SATA channel>  at channel 6 on mvs0
> mvsch7:<Marvell SATA channel>  at channel 7 on mvs0
> ada0 at mvsch0 bus 0 scbus0 target 0 lun 0
> ada0:<OCZ-AGILITY2 3.5 1.11>  ATA-8 SATA 2.x device
> ada0: 300.000MB/s transfers (SATA 2.x, UDMA6, PIO 2048bytes)
> ada0: Command Queueing enabled
> ada0: 85857MB (175836528 512 byte sectors: 16H 63S/T 16383C)
> ****************************************************************************
> I don't know enough to understand whether "using mvs" has a chance of
> working for me.  If it might, how do I "use mvs" when attempting to
> install?  (The DVD does have the fixit environment available.)
> Thanks in advance for any helpful suggestions,
> Jud

Try the ahci driver or lower the speed to 3Gbps and see if that works.


More information about the freebsd-questions mailing list