FreeBSD 8, serial console problem

Brian Wolman jeep at
Tue Mar 23 02:36:05 UTC 2010

FreeBSD 8 uses the uart system to handle serial consoles, I changed mine
over and I've been running into problems since.

I have serial console access during the loader and boot process, but it
freezes right after boot and posting of the date:

Mon Mar 22 22:18:08 EDT 2010

Well, the kernel still outputs to the console, as evident when I plugged
in a keyboard into the usb slot:

ugen1.2: <vendor 0x046d> at usbus1
uhub5: <vendor 0x046d G15 Keyboard Hub, class 9/0, rev 1.10/0.20, addr
2> on usbus1
( (ttyu0)

login: uhub5: 4 ports with 2 removable, bus powered

I typed 'root' and then it froze. Again, I plugged in the keyboard, but
this time I couldn't type anything despite getting another login prompt.
I even echoed to the console and it worked. Finally I typed kldload uart
into my ssh terminal and poof:

FreeBSD/i386 o( (ttyu0)
login: jjjjjhlgf

e_register: module isa/uart already exists!
Module isa/uart failed to register: 17
module_register: module pci/uart already exists!
Module pci/uart failed to register: 17

I was able to login and everything worked fine.
Notice how uart already exists.. it's compiled into the kernel. Right
now the only way I've come up with to fix my broken console is to
kldload, but I can only do it once per boot. If it breaks after that,
I'm out of luck until I reboot.

More information about the freebsd-questions mailing list