VirtualBox from the command line

Aiza aiza21 at
Fri Mar 19 03:46:54 UTC 2010

> On Thu, Mar 18, 2010 at 7:44 PM, Aiza <aiza21 at 
> <mailto:aiza21 at>> wrote:
>     Does VirtualBox launch from the FBSD command line?
>     Is there a package for it in the pkg system?
> # VirtualBox -h
> Sun VirtualBox Graphical User Interface 3.1.2_OSE
> (C) 2005-2009 Sun Microsystems, Inc.
> All rights reserved.
> Usage:
>   --startvm <vmname|UUID>    start a VM by specifying its UUID or name
>   --rmode sdl|image          select different render mode (default is sdl)
> There are other ways too, eg VBoxHeadless
> -- 
> Adam Vande More

I read the VirtualBox section in the handbook. Not very informative.
I also read the VirtualBox manual here
The VirtualBox website shows a GUI manager for 
configuring the host and guest setups. I did

pkg_add -r virtualbox

During the install got these messages

Your SDL library has been built with libvgl support, which means that 
you  can run almost any SDL application straight on your console (VESA 
2.0  compatible videocard is required). To do this you have to load the 
vesa kernel module or enable it in your kernel, and set environment 
variable "SDL_VIDEODRIVER=vgl".

Since i Want to run virtualbox under vga I did this
added vesa_load="YES" to /boot/loader.conf

At the end of the package install it says to
Add vboxdrv_load="YES"   to /boot/loader.conf
and reboot which i did.

before launching do
mount -t procfs proc /proc
pw groupmod vboxusers -m root

To launch it enter VirtualBox on the command line.
[take special note of the capital letters V & B in
the command name]

I get msg  "Failed to open the X11 display."

tried starting VBoxSDL   get this error
VBoxSDL: Error -1908 in suplibOsInit!
VBoxSDL: Kernel driver not installed
VBoxSDL: Tip! Make sure the kernel module is loaded.
It may also help to reinstall VirtualBox.

Tried starting  VBoxManager
VBoxManager: Command not found.

Tried starting VBoxHeadless
VBoxHeadless: Error -1908 in suplibOsInit!
VBoxHeadless: Kernel driver not installed
VBoxHeadless: Tip! Make sure the kernel module is loaded.
It may also help to reinstall VirtualBox.

Why don't virtual box GUI start in vga mode?

Is this telling me that I have to have Xorg and some
desktop running before VirtualBox's gui will function?

Are the scripts provided by vboxtool the only way to have
command line control of VirtualBox?

See talk about vboxweb as alternate VirtualBox manager.
Does not look like this is out of development yet.
Anybody using this?

More information about the freebsd-questions mailing list