X not responding

Richard T C Farnes rcfarnes at broadpark.no
Wed Jun 23 21:00:48 UTC 2010

On Tuesday 22 June 2010 19:52:54 Andy Balholm wrote:
> I am having a problem with Xorg under FreeBSD 8.0 RELEASE and 8.1 RC1:
> When I type startx, the X server starts, and some xterm windows open, but
> it will not respond to keyboard or mouse input. The mouse pointer won't
> move, and the only keyboard input that does anything is CTRL-ALT-F1 etc. to
> switch virtual terminals.
> If I install FreeBSD 7.1, which installs Xorg straight from the
> installation CD, it works fine. Under version 8, I've tried installing from
> ports and packages, and I get this problem.
> When I first had this problem, I was running it under VirtualBox, so I
> thought maybe it was because VirtualBox's FreeBSD support is incomplete.
> But now I've tried it on real PC hardware, and I have the same problem.
> Obviously some people must be running X under FreeBSD 8, so I must be doing
> something wrong in my installation or configuration, but I can't guess what
> it is.
> Andy Balholm
> (509) 276-2065
> andy at balholm.com
> _______________________________________________
> freebsd-questions at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to
> "freebsd-questions-unsubscribe at freebsd.org"

Here it looks like you have made some mistakes in the configuring file for X. 
You did not mention that  you have configured it. After X has been installed 
you must  go into the X configuration file and configure  your keyboard and 
mouse etc  for use with it. When I installed X on my version 7 BSD I had to 
use some time tuning this file so X would work properly. The file gives you 
alternatives like which language keyboard you use and how your mouse works 
and other settings.

Richard Farnes

More information about the freebsd-questions mailing list