undefined reference to `SSL_SESSION_cmp'

Ewald Jenisch a at
Wed Jun 23 09:08:30 UTC 2010


During upgrading my ports I run into very nasty problems compiling
e.g. sound-juicer or libmisicbrainz3, or more generally, ports that
depend on neon28:

Compilatino of e.g sound-juicer stops with the following error:

------------------------------ < Cut here > ------------------------------

gmake[3]: Leaving directory `/usr/ports/audio/sound-juicer/work/sound-juicer-2.28.2/libjuicer'
gmake[2]: Leaving directory `/usr/ports/audio/sound-juicer/work/sound-juicer-2.28.2/libjuicer'
Making all in src
gmake[2]: Entering directory `/usr/ports/audio/sound-juicer/work/sound-juicer-2.28.2/src'
  CC     sound_juicer-sj-main.o
  CC     sound_juicer-sj-prefs.o
  CC     sound_juicer-sj-play.o
  CC     sound_juicer-sj-about.o
  CC     sound_juicer-sj-extracting.o
  CC     sound_juicer-sj-inhibit.o
  CC     sound_juicer-sj-genres.o
  CC     sound_juicer-gedit-message-area.o
  CC     sound_juicer-gconf-bridge.o
  CC     sound_juicer-egg-play-preview.o
  CC     sound_juicer-bacon-message-connection.o
  CXXLD  sound-juicer
/usr/local/lib/ undefined reference to `SSL_SESSION_cmp'
gmake[2]: *** [sound-juicer] Error 1
gmake[2]: Leaving directory `/usr/ports/audio/sound-juicer/work/sound-juicer-2.28.2/src'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/ports/audio/sound-juicer/work/sound-juicer-2.28.2'
gmake: *** [all] Error 2
*** Error code 1

Stop in /usr/ports/audio/sound-juicer.

------------------------------ < Cut here > ------------------------------

/usr/local/lib/ comes from /usr/ports/www/neon28, so I did a
de-install, make clean, make install of neon28. Compilation &
installation went OK, however when I tried to compile sound-juicer
again I got the error "/usr/local/lib/ undefined reference
to `SSL_SESSION_cmp'.

Please note that I've got openssl installed from ports,
i.e. /usr/ports/security/openssl. neon28 correctly lists it as

# pkg_info -rx neon28
Information for neon28-0.28.6_1:

Depends on:
Dependency: expat-2.0.1_1
Dependency: openssl-1.0.0_2
Dependency: libiconv-1.13.1_1
Dependency: gettext-0.18_1

I even tried to do a portupgrade -frR neon28 - again stops with the
error above :-(

So here are my questions:

o) Has anybody out there seen this before?

o) Any known cure against it?

Thanks much in advance for any clue,

More information about the freebsd-questions mailing list