X not responding

Andy Balholm andy at balholm.com
Tue Jun 22 18:19:39 UTC 2010

I am having a problem with Xorg under FreeBSD 8.0 RELEASE and 8.1 RC1:

When I type startx, the X server starts, and some xterm windows open, but it will not respond to keyboard or mouse input. The mouse pointer won't move, and the only keyboard input that does anything is CTRL-ALT-F1 etc. to switch virtual terminals.

If I install FreeBSD 7.1, which installs Xorg straight from the installation CD, it works fine. Under version 8, I've tried installing from ports and packages, and I get this problem.

When I first had this problem, I was running it under VirtualBox, so I thought maybe it was because VirtualBox's FreeBSD support is incomplete. But now I've tried it on real PC hardware, and I have the same problem.

Obviously some people must be running X under FreeBSD 8, so I must be doing something wrong in my installation or configuration, but I can't guess what it is.

Andy Balholm
(509) 276-2065
andy at balholm.com

More information about the freebsd-questions mailing list