Running Older Binaries under 8.0

Chuck Swiger cswiger at mac.com
Mon Jun 21 20:56:34 UTC 2010


Hi--

On Jun 21, 2010, at 1:52 PM, Martin McCormick wrote:
> 	I have a large number of home-grown applications that
> run under FreeBSD 6.3 and earlier. As we transition to
> FreeBSD8.0, is there a good single package to add which will
> provide the right libraries to allow these older binaries to run
> without surprises?

Yes, you want:

  /usr/ports/misc/compat6x

It installs the libraries from FreeBSD-6.x under a compatibility location so that your older binaries should run without needing to be recompiled....

Regards,
-- 
-Chuck



More information about the freebsd-questions mailing list