SATA time outs

Matthew Seaman m.seaman at
Tue Jun 15 15:42:32 UTC 2010

Hash: SHA1

On 15/06/2010 16:06:36, Casey Scott wrote:
> I'd appreciate it if someone could lend some assistance with this
> issue. The machine in question is pretty much unusable atm!

You've tried swapping out the drives and the disk controllers, but have
you tried swapping out the SATA cables?  I say this, because I
personally once spent about two weeks trying to debug a weird problem
that turned out to be due to a broken conductor in some ethernet cable.
Talk about egg-on-face.

When doing diagnosis by swapping out components, always start with the
cheapest components and work up to the most expensive.

Now, component failure is certainly a possibility given that you say the
kit is some years old.  That can be a side effect of upgrading to a new
release -- if you're doing a lot of extra compiling and stuff the extra
load can tip marginal hardware over the edge -- but it is a also
possibility that there is some sort of introduced bug with the new system.

To confirm this, you'll need to boot back into an older version of the
system and show that all your hardware comes back to life.  Rather than
blowing away all your upgrading work, try using a livecd -- you can fsck
and mount 8.0 UFS filesystems from a 7.x livecd no problem, but be
careful with ZFS, as there may have been some on-disk format changes
that aren't backwards compatible.  You might want to grab an 8-STABLE
snapshot .iso as well: if that works, then you can be fairly certain the
problem will be fixed in 8.1-RELEASE  (although there has definitely
been a zpool version bump between 8.0-RELEASE and 8.1-RELEASE).



- -- 
Dr Matthew J Seaman MA, D.Phil.                   7 Priory Courtyard
                                                  Flat 3
PGP:     Ramsgate
JID: matthew at               Kent, CT11 9PW
Version: GnuPG/MacGPG2 v2.0.14 (Darwin)
Comment: Using GnuPG with Mozilla -


More information about the freebsd-questions mailing list