Sudden refusal to boot with page fault in swapper

Matthew Hambley matthew.hambley at
Mon Jun 14 10:08:39 UTC 2010

My FreeBSD system (amd64, SATA, root on ZFS) has suddenly started 
refusing to boot up. It crashes out with a page fault just after the ZFS 
warning that I "only" have 4GB of RAM.

The following is a transcription of what I see:

> ZFS file system version 13
> ZFS storage pool version 13
> Timecounters tick every 1.000msec
> Fatal trap 12: page fault while in kernel mode
> cpuid = 0; apic id = 00
> fault virtual address = 0x4
> fault code = supervisor write data, page not present
> instruction pointer = 0x20:0xf...810c522a
> stack pointer = 0x28:0xf...81128af0
> frame pointer = 0x28:0xf...81128b10
> code segment = base 0x0, limit 0xfffff, type 0x1b
>              = DPL 0, pres 1, long 1, def32 0, gran 1
> processor eflags = interupt enabled, resume, IOPL = 0
> current process = 0 (swapper)
> trap number = 12
> panic: page fault
> cupid = 0
> uptime : 1s
> Cannot dump, Device not defined or unavailable
> Automatic reboot in 15 seconds

The ellipses in addresses represents continued f's. These addresses seem 
to be the same each time. I have tried using the "Without ACPI" boot 
option to no avail.

Originally I had a problem in that using a USB keyboard meant I was 
unable to press a key to halt the reboot timer but a USB to PS/2 adapter 
solved that.

This problem has suspiciously started happening after I had trouble 
performing the big "gettext" upgrade to the ports tree but I don't see 
how changes to the ports tree can affect the base system which is 
presumably where I still am this early in the boot process. However, for 
completeness, the "portmaster -w -r gettext" command kept failing half 
way through over the "xz" archiver. In the end I gave up and went with a 
"portmaster -a" expecting some minor problems which could be fixed with 
manual recompilation of effected ports.

While some web searching didn't turn up an answer to my problem it did 
show that a memory fault is often suspected in these situations. I used 
an "Ultimate Boot" disc to test the memory and it tested okay.

Have I hosed my system? And help gratefully received.


More information about the freebsd-questions mailing list