spamd exits on line 2585 unexpectedly... .

RW rwmaillists at
Tue Jun 8 22:47:00 UTC 2010

On Tue, 8 Jun 2010 10:51:28 -0700
Gary Kline <kline at> wrote:

> 	anybody know why /usr/local/bin/spamd bailed on me like this? 
> child process [2377] exited or timed out without signaling
> production of a PID file: exit 25 at /usr/local/bin/spamd line
> 2585.

This was discussed on the ports list some time ago - I don't think they
came to any real conclusion. Someone said that sa-update had solved it,
someone fixed it by deleting and then reinstalling relevant ports.

> 	seems to have begun while i was upgrading my server, but
> 	beyond that, i'm wedged.  i would like to install dspam
> 	*with* this--spamassassin, if that will work.  not entirely
> 	sure how to make that happen.

The easiest way to do that is to pipe it though dspam 

  dspam --stdout --deliver=innocent,spam

and then add an SA header test like:

  header   DS_SPAM        X-DSPAM-Result =~ /^Spam/
  tflags   DS_SPAM        learn
  score    DS_SPAM        3.5 

More information about the freebsd-questions mailing list