minicom freebsd 8.0

akash kumar akashb503 at
Tue Jun 8 10:46:06 UTC 2010


Finally worked for me. Thanks all for your help.
Below are the steps.

1. /var/log/messages has below message when ever usb port is inserted. 
> Unknown USB device: vendor 0x4348 product* 0x5523* bus uhub2 

2. grepping for vendor no. 
> grep 0x4348 /usr/src/sys/dev/usb/* 
/usr/src/sys/dev/usb/usbdevs:vendor WCH        0x4348    QinHeng Electronics 

> cat /usr/src/sys/dev/usb/usbdevs | grep WCH 
vendor WCH        0x4348    QinHeng Electronics 
/* WCH products */ 
product WCH CH341SER        *0x5523 *   CH341/CH340 USB-Serial Bridge 
product WCH2 CH341SER        0x7523    CH341/CH340 USB-Serial Bridge 

3. After bit of googling with 'CH341/CH340 USB-Serial Bridge', found that specific module is missing.
  Added uchcom in to the config file and rebuilt the kernel and booted 
with it. 
> kldstat -v | grep uchcom 
       309 uhub/uchcom 

4. After rebooting could see below messages i.e device being recognized 
as the module is already present 
ugen2.3: <vendor 0x4348> at usbus2 
ucom0: <vendor 0x4348 USB-SER!, rev 1.10/2.50, addr 3> on usbus2 
ucom0: CH340 detected 

The device is created with name  /dev/cuaU0 and it worked finally with minicom. 


From: C. P. Ghost <cpghost at>
To: akash kumar <akashb503 at>
Cc: freebsd-questions at
Sent: Wed, 2 June, 2010 3:36:54 PM
Subject: Re: minicom freebsd 8.0

On Wed, Jun 2, 2010 at 11:30 AM, akash kumar <akashb503 at> wrote:
> Hi,
> I was referring to minicom command similar to one on linux.
> On linux the config file is /etc/minirc.<configfile> and the  Serial Device is  /dev/ttyUSB0, which was working for me.
> On freebsd  the config file is /usr/local/etc/minicom/minirc.<configfile>, but not sure what to update in the field 'pu port'.
> I tried with /dev/ugen2.2 but got below error
>> minicom: cannot open /dev/ugen2.2: Permission denied
> Please let me know what needs to be updated in the 'pu port' field.

Ah, okay. ugen is a generic device. I think you can't use that directly
if you have a usb-to-serial converter.

I guess you need to kldload a kernel module specific to your usb-to-serial
converter. For example something like uplcom, umodem etc. This would
create a new entry in /dev that you can use in minicom.

Permissions for those devices can be set in /etc/devfs.rules (and restarting
devfs with /etc/rc.d/devfs restart). You may also want to look at /etc/devd.conf

I'm not familiar with usb-to-serial converters, so I can't help more than that.
Others may have more experience there.

> Thanks,
> Akash.


Cordula's Web.

More information about the freebsd-questions mailing list