hal-0.5.14_7 to _8 upgrade problem

n dhert ndhertbsd at gmail.com
Mon Jun 7 08:54:52 UTC 2010


Hi,
OK, the next day the TAB was OK again after the recompile of kdebase (part
of the necessary recompiles specified in /usr/ports/UPDATING - 20090309)
This was on a system already on 8.0 (upgraded from 7.2)
But I have another issue with that libusb on another system, which is stil
7.2.
I want to do the same thing there as described in UPDATING - 20090309

But after pkg_delete,
pkg_delete: package 'libusb-0.1.12_4' is required by these other packages
and may not be deinstalled (but I'll delete it anyway):
hplip-3.10.5_1
kdebase-3.5.10_7
kdepim-3.5.10_7
kdeutils-3.5.10_5

at the
# cat ${tempfile} | xargs portupgrade -f --batch --yes | tee
/tmp/portupgrade-libusb

it first reinstalls  libusb-0.1.12_4  again !?
(This is installed as a dependency of hplip-3.5.10_1)

Why ??

After pkg_delete -f /var/db/pkg/libusb-* I did a
# pkgdb -F
--->  Checking the package registry database
Stale dependency: hplip-3.10.5_1 -> libusb-0.1.12_4 (devel/libusb):
libutempter-1.1.5_1 (score:21%) ? ([y]es/[n]o/[a]ll) [no]   geef:  y
Fixed. (-> libutempter-1.1.5_1)
Stale dependency: kdebase-3.5.10_7 -> libusb-0.1.12_4 (devel/libusb):
libutempter-1.1.5_1 ? ([y]es/[n]o/[a]ll) [yes]      geef: enter voor yes
Fixed. (-> libutempter-1.1.5_1)
Stale dependency: kdepim-3.5.10_7 -> libusb-0.1.12_4 (devel/libusb):
libutempter-1.1.5_1 ? ([y]es/[n]o/[a]ll) [yes]      geef: enter voor yes
Fixed. (-> libutempter-1.1.5_1)
Stale dependency: kdeutils-3.5.10_5 -> libusb-0.1.12_4 (devel/libusb):
libutempter-1.1.5_1 ? ([y]es/[n]o/[a]ll) [yes]      geef: enter voor yes
Fixed. (-> libutempter-1.1.5_1)
Did I do something wrong here?

The only difference I see is that I now still am on 7.2, but it should be
doing it also
what is missing ?


2010/6/6 Lowell Gilbert <freebsd-questions-local at be-well.ilk.org>

> n dhert <ndhertbsd at gmail.com> writes:
>
> > But is there a workarround somehow in case I DO need to specify options
> > different from the default ??
> > I'd really want to know that, for in case ...
>
> "cd /usr/ports/x11/kdebase4 && make config"
>
> This is covered in "man ports".
>


More information about the freebsd-questions mailing list