Continuing problem with NVIDIA Driver

Pieter de Goeje pieter at
Sun Jun 6 17:24:01 UTC 2010

On Sunday 06 June 2010 17:12:46 Jerry wrote:
> FreeBSD-8.0 STABLE / amd64
> After updating (gettext) the NVIDIA driver no longer worked in Xorg, nor
> was it being loaded at boot-up even thought it was in
> the /boot/loader.conf file and had worked correctly priviously. I am
> also unable to load it manually.
> kldload nvidia
> KLD nvidia.ko: depends on kernel - not available or version mismatch
> linker_load_file: Unsupported file type
> kldload: can't load nvidia: Exec format error
> kldstat
> Id Refs Address            Size     Name
>  1   12 0xffffffff80100000 ddd800   kernel
>  2    1 0xffffffff81022000 399f     linprocfs.ko
>  3    1 0xffffffff81026000 1c4e8    linux.ko
> "kldstat -v" doesn't reveal anything interesting either.
> I have removed and reinstalled the NVIDIA driver
> (nvidia-driver-195.36.15) twice without any success.
> This only started after updating 'gettext'. Everything else appears to
> be working correctly.

Are your kernel sources in sync with the kernel you're running? Did you 
rebuild the driver? (i.e. make deinstall clean && make reinstall clean)
You need to have the exact version of the sources you used to build the 

Pieter de Goeje

More information about the freebsd-questions mailing list