Continuing problem with NVIDIA Driver

Jerry freebsd.user at
Sun Jun 6 15:13:01 UTC 2010

FreeBSD-8.0 STABLE / amd64

After updating (gettext) the NVIDIA driver no longer worked in Xorg, nor
was it being loaded at boot-up even thought it was in
the /boot/loader.conf file and had worked correctly priviously. I am
also unable to load it manually.

kldload nvidia

KLD nvidia.ko: depends on kernel - not available or version mismatch
linker_load_file: Unsupported file type
kldload: can't load nvidia: Exec format error


Id Refs Address            Size     Name
 1   12 0xffffffff80100000 ddd800   kernel
 2    1 0xffffffff81022000 399f     linprocfs.ko
 3    1 0xffffffff81026000 1c4e8    linux.ko

"kldstat -v" doesn't reveal anything interesting either.

I have removed and reinstalled the NVIDIA driver
(nvidia-driver-195.36.15) twice without any success.

This only started after updating 'gettext'. Everything else appears to
be working correctly.

FreeBSD.user at

Disclaimer: off-list followups get on-list replies or get ignored.
Please do not ignore the Reply-To header.

If any man wishes to be humbled and mortified,
let him become president of Harvard.

	Edward Holyoke
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 488 bytes
Desc: not available
Url :

More information about the freebsd-questions mailing list