Upgrade 6.4-stable to 7.3

Erich Dollansky erichfreebsdlist at ovitrap.com
Wed Jul 28 10:47:20 UTC 2010


I did a source upgrade on one box from 6.4 to 7.2 or 7.3 without any problems.

I later did a source upgrade to 8.0 on the same machine just to find out that USB has some problems, I went then back to 7.3 on this machine.

I also did some source upgrades from 7.x to 8.0 on some other machines without any problems.

On Tuesday 27 July 2010 22:02:48 Michael Doyle wrote:
> In the past, I've usually done a wipe-and-reinstall when moving  
> between major version numbers
> but I would rather avoid that this time around.

I never did this since 5.2. The upgrades always worked for me.
> Also, would people recommend staying with version 7.3 or jumping all  
> the way to version 8.1 ?

I would first install 7.3, check if all works and then do a source upgrade. Save the source tree for 7.3 just for the case you have to go back.
> CPU: Intel(R) Pentium(R) 4 CPU 2.80GHz (2800.11-MHz 686-class CPU)
>    Origin = "GenuineIntel"  Id = 0xf41  Stepping = 1

Not so new. Just like the machine which gave me the problem with 8.0. I never tried 8.1 on this machine.
> uhci0: <UHCI (generic) USB controller> port 0xcce0-0xccff irq 20 at  
> device 29.0 on pci0
> uhci0: [GIANT-LOCKED]
> usb0: <UHCI (generic) USB controller> on uhci0
> usb0: USB revision 1.0
> uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
> uhub0: 2 ports with 2 removable, self powered

Somewhere here were the problems.

> uhub1: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1

You have Intel, I have NEC, so, you should not face the same problems I did. If they are not solved meanwhile.

> atkbd0: <AT Keyboard> irq 1 on atkbdc0
> kbd0 at atkbd0
> atkbd0: [GIANT-LOCKED]
> psm0: <PS/2 Mouse> irq 12 on atkbdc0

Just one note. You are managing this machine remotely? No X on it?

Take the two step approach and you should have a running system afterwards.


More information about the freebsd-questions mailing list