autologin KDE, 8-1-RELEASE-amd64 not working

Antonio Olivares olivares14031 at gmail.com
Wed Jul 28 02:18:43 UTC 2010


On Tue, Jul 27, 2010 at 1:31 PM, Thiago Rodrigues Santos
<trsantos1 at gmail.com> wrote:
> Em Terça-feira 27 Julho 2010, às 14:58:33, Antonio Olivares escreveu:
>> Dear folks,
>>
>> I am not sure why, but autologin is not working, I get authentication
>> errors :(
>>
>> I setup KDE as the desktop using
>>
>> echo 'exec /usr/local/kde4/bin/startkde4' > ~/.xinitrc
>>
>> echo 'local_startup="${local_startup} /usr/local/kde4/etc/rc.d"' >>
>> /etc/rc.conf echo 'kdm4_enable="YES"' >> /etc/rc.conf
>>
>> and logging in as root and using the System Settings, I chose
>> autologin as myself(regular user, member of wheel/operator groups(if
>> it is important))     but I get authentication error :(
>>
>> I try to login as root, but root is not allowed exept if I start in
>> console mode, i,e, comment out the lines in /etc/rc.conf and I make
>> changes, but cannot get autologin to work.
>>
>> I know that autologin is discouraged, but this is a home computer and
>> no other person uses it execpt me, how should I fix it?
>>
>> Thank you for advice/suggestions/comments.
>>
>> Regards,
>>
>> Antonio
>> _______________________________________________
>> freebsd-questions at freebsd.org mailing list
>> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
>> To unsubscribe, send any mail to
>> "freebsd-questions-unsubscribe at freebsd.org"
>
> Hello. If you don't have the /etc/pam.d/kde-np file, you need to create it
> with the following content:
>
> auth       required     pam_permit.so
> account    required     pam_nologin.so
> account    required     pam_unix.so
> session    required     pam_permit.so
>
> --
> Thiago Rodrigues Santos <trsantos1 at gmail.com>
> _______________________________________________
> freebsd-questions at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at freebsd.org"
>

Thank you very much Thiago.  Creating the file and restarting worked :)

Now, I will try to compile some programs like mplayer.

Regards,

Antonio


More information about the freebsd-questions mailing list